Funky Toon material (Resolved, maybe!)

Started by Speedster, December 31, 2018, 09:43:29 AM

Previous topic - Next topic

0 Members and 1 Guest are viewing this topic.


Got a problem!

The "Toon" material is funky now in 8.1.61.  Regardless of Fill, Outline or whatever, it now comes in as solid black.  You can tweak the color, but Environmental Shadow does not work, nor do any of the other tweaks.  Happened in 8.1.59, and now in 8.1.61, which is today's update.

What's interesting is that if I open a Toon project created in KS7, the materials from KS8 behave as they should.  This issue only appears to apply to new work.

Screenshots below...

Any clues?

Bill G


Yikes!  Even worse than I thought!

After opening a KS7 .bip in KS8.1.61 the Toon material looked fine.


All I got was solid black when I rendered it out!


Bill G


Hi Bill,

Would you be able to share the model with us (using wetransfer to Then we can take a look and make sure it is working for you.



Hi Bill,

Thank you for providing the model. I just loaded it. It looks fine on my end. I am using KeyShot 8.2, which is in Q&A right now. If you are interested we can get you setup with a beta of KeyShot 8.2 (just email us at




You have "contour width in pixels" enabled and you are rendering at a much higher resolution than your real-time view.

Try disabling this option and adjust contour width accordingly to have a consistent output from the rt view to output regardless of resolution.


QuoteYou have "contour width in pixels" enabled and you are rendering at a much higher resolution than your real-time view.
Yep, unchecking Width in Pixels did the trick.  Thanks!

Which begs the question- all of my toon materials are default in pixel width.  Why is this even an option?  It would seem that it should be default without pixel width, and that option just goes away.  Or why would you want to use pixel width in the first place?

Also, with it unchecked, the width becomes extremely sensitive.  Like I had to drop it way down to 0.00233, and even a .001 change trashes it...

Bill G


Glad to hear. The reason this is enabled is that it provides better visual results with default values than when using units.


QuoteThe reason this is enabled is that it provides better visual results with default values than when using units.
That makes no sense to me.  Solid black is certainly not a better visual result.

It's puzzling, as Toon has worked perfectly ever since it was introduced.  It's frustrating to me, as I use Toon for many Design Patent drawings.  Also, I'm developing a whole new series of giclee prints using toon.


After following the advice, I was able to create the "Speedster" image, first up below, after two passes through FilterForge and a final tweak in Luminar.  Prints great on MOAB Museum Matte media.

I saved the new toon material in the toon folder and closed down.  Then I opened the GG1 locomotive model, and dropped the now saved new toon on the top assembly in the scene tree, as I always do.

And again, it came in as all black, but with all of the tweaked settings from before.

I give up- it's back to KeyShot 7, unfortunately.

Bill G


What are your units in the speedster scene? I can see that you don't have units assigned to the locomotive scene which means it will use meters as the default.


Following this with interest. I'm using KS 8.1.61 and everything seems to be working fine for me.
This scene uses 'Toon Shaded xx' materials throughout and it seems to both display and render just fine with 'Contour width in pixels' checked. I played about a bit with the 'shaded white' material in the scene and could not replicate Bill's problem.
If I uncheck 'Contour width in pixels'' and adjust the (mm) contour width to, say, 0.1mm the real-time display is similar and when I do a time-based render it gives the expected (good) result.
I tried applying the material to a KS7 model and had no problems.
I can't get the 'all-black' effect unless I bump up the contour width to something extreme like 10mm or so.


Well, I woke up this morning determined to do a forensic analysis of this, so I fired up the computer and opened a new KS7 scene. 

Dropped in the SolidWorks Top Assembly of another model (fire truck) and all is well.  Units are set as inches.  Toon looks great as always!

Then I opened a new KS8 scene and did the same.  Units are in inches per my long time preference.  Toon looked great!

Figured it only needed a cold reboot.


Then I opened the GG1 locomotive as the existing .bip, set the units to inches, and everything disappeared.  Went back to meters, tried the toon material again, and ended up with all black.

The Speedster and locomotive were both legacy KS7, but all was well if I started from scratch.  Only crapped out with a legacy.

I still don't understand what's happening, but no biggie as a Toon only takes a few minutes from scratch.

Puzzling!  But I consider this resolved.

Bill G