Render layer doesnt work on 9.1 either

Started by Andrew_G, February 11, 2020, 12:32:56 AM

Previous topic - Next topic

0 Members and 1 Guest are viewing this topic.



I just installed KS 9.1. When installation was finished first thing I did was check if render layers works on GPU as it should. Unfortunately it doesnt. I run some tests, and on simple scenes it looks like everything is correct. But with my "normal" work files it still doesnt work as it should.

I attach of one of my simplified scene. Just hit render, and you will see that not all parts of the book are in the Render Layer Group. Some of them are gone. On CPU mode everything is fine.

Is there any way to fix it?

PS. I just found out, that Clown Pass doesnt work either when GPU rendering is turned on.


Hello Andrew,

Thank you for letting us know about this bug.

It looks like the render layers are assigned wrongly, as the content of the layer "Pages 2" is actually what should be in "Cover 1"
It's not a great workaround, but adding another render layer with some geometry you don't need in it at the bottom of the list will render all other layers, but the naming will still be off by one.

As for the clown pass, I can not see any issue there. Your scene only contains two materials, one for the glue, and one for everything else. That's why it becomes almost one solid color.


Hello again,

We just found a much better fix.
You have an empty render layer in your scene, if you delete that it will work without issue.


Hi Sune,

Thanks for your reply and fix. I will use it for sure. But still there is a bug. If you switch to CPU mode all those fixes will be unnecesary, as all Render Layers will work perfectly.

I often work on much more complicated scenes (we all do:) ) and sometime it is really difficult to dermine if some render layer is empty or not. It would be great if it would work as it should:)


Yes do not worry, the bug has been filed and is being worked on.


Thanks Sune,  thats all I wanted to hear:)