Author Topic: had to disable GPU mode  (Read 1800 times)

0 Members and 1 Guest are viewing this topic.

Offline andy.engelkemier

had to disable GPU mode
« on: February 13, 2020, 05:01:32 am »
I enabled GPU mode, yay! But it the computers that had CPU and GPU enabled weren't picking up render jobs. Turning GPU off solved the issue.

Also, I didn't see anywhere that tells me the limits of GPU mode. All I know is I can't render 7K or 5K. So how big Can you go? 5K is my minimum render size, so that pretty much eliminates the use for me. Is it only for animations? That would have been nice to know.

Offline jhapeman

Re: had to disable GPU mode
« Reply #1 on: August 16, 2020, 06:12:36 pm »
Old topic and I might not be right on this but I suspect your problem with your scenes is that they require more memory than your GPU has; if there's not enough memory on the GPU KeyShot will fall back to CPU rendering.

Offline andy.engelkemier

Re: had to disable GPU mode
« Reply #2 on: September 18, 2020, 06:47:23 am »
No, there's definitely more going on there that is messing up. I even confirmed one issue, that sending GPU to the farm causes camera shift to mess up the background. There are other issues as well.

But the issue we have with having GPU enabled at ALL on the farm, is that it forces the machine to be GPU only. So if I have CPU and GPU on all the machines (at one point we did) and then send a CPU job, it won't render at all.

We've switched the machines all back to CPU. It'll probably be something that is slightly improved in keyshot 10. Hopefully that doesn't come with too many new issues. But there are still things we can't render in GPU mode anyway. A huge one for me is making thin glass not cast shadow. There's just no reason to calculate caustics, or even GI, for something that you wouldn't notice. So you can use RayMask to have a thin piece of glass not cast shadow....but not with GPU mode. So if I'm rendering something like a coffee pot, I'm stuck with CPU mode for now. So that goes to the farm. If it's GPU mode I just render it on my machine. (which happens to be faster than all 64 threads on the farm machines all by itself. lol). Too bad I can't render most things in GPU on the farm, because then it would be Blazing fast. Well, I guess I can only use two machines since GPU mode takes up 32 threads. Which sort of sucks because it's almost just worth opening the file on multiple machines so you can utilize rendering in keyshot instead. That's just more manual work. It's a shame each license of keyshot doesn't allow for render nodes in addition to the ones you purchase.