9.0 to 9.1.98 Discrepancy in droplets (non-caustics)

Started by DMerz III, February 12, 2020, 08:17:15 AM

Previous topic - Next topic

0 Members and 1 Guest are viewing this topic.


Originally posted this in the KS 9.1 Beta thread - but that has been locked.

So reposting here with more tests and more info.
I would classify this as a bug since it was something that was working a certain way - and now is broken.

Windows 10 Pro
Tested on multiple PCs - all showing the same results
Xeon processors

Can is a 'metal' shader with a 'plastic' label. Stripe is opacity cut out of the label to the 'can'. It's not related to drops on a label as I've tried turning label off making can itself plastic.

This is a major problem for us since the workflow is established and we've gone with these exact settings for 1000s of renders using KS8
Switching to GPU does look 'better' here but is not an option right now as our equipment is all CPU pipeline.

Justin A

Hello Dmerz,

I have been trying to reproduce the issue you are having without success.
Would you be able to share the KSP so that I can do a bit more troubleshooting?

or at least a scene that has the problem in it?

Luxion support


Just made a new scene - Created a closed cylinder - added closed spheres scattered all over - the spheres are nested into the surface of the cylinder.
Getting same result.

Do note - the Realtime View does differ from the Render Output - In the realtime view the drops will be darkened (also a new behavior in 9.1 from 9.0 & 8.0) - but in the rendered output (shown) - it is completely blacked out.

Sending the .ksp of this to you via your wetransfer.

Justin A

Thank you for the scene,

I am currently taking a look at this and with collaboration from my development team I hope to have some answers for you shortly.

Thanks again


Thanks, Justin. The team and I are eagerly awaiting.

Hopefully, it can be resolved soon! We know it was working with 9.0!