Author Topic: Disappearing parts after splitting parts using Edit Geometry  (Read 595 times)

0 Members and 1 Guest are viewing this topic.

Offline Lars

  • Newbie
  • *
  • Posts: 13
Disappearing parts after splitting parts using Edit Geometry
« on: February 25, 2020, 04:20:20 am »
It has happened loads of times for me.
I edit a model using edit geometry, Everything is fine until I save, close, open again and all the parts are gone. It's incredibly frustrating as I lose hours of work every time it happens.

Does this happen to anyone else?

I have seen this on here before but the problem persists and to export the parts as obj, is a painful workaround.

There are a whole bunch of errors in the Log:

(12:21:29) Invalid id [1599954390] specified for lux_object_from_id
(12:21:29) Invalid id 1599954390 specified for instance
(12:21:29) Invalid id [1599954391] specified for lux_object_from_id
(12:21:29) Invalid id 1599954391 specified for instance
(12:21:29) Invalid id [1599954392] specified for lux_object_from_id
(12:21:29) Invalid id 1599954392 specified for instance
(12:21:29) Invalid id [1599954390] specified for lux_object_from_id
(12:21:29) Invalid id 1599954390 specified for instance
(12:21:29) Invalid id [1599954391] specified for lux_object_from_id
(12:21:29) Invalid id 1599954391 specified for instance
(12:21:29) Invalid id [1599954392] specified for lux_object_from_id
(12:21:29) Invalid id 1599954392 specified for instance
(12:21:29) Invalid id [1599954390] specified for lux_object_from_id
(12:21:29) Invalid id 1599954390 specified for instance
(12:21:29) Invalid id [1599954391] specified for lux_object_from_id
(12:21:29) Invalid id 1599954391 specified for instance
(12:21:29) Invalid id [1599954392] specified for lux_object_from_id
(12:21:29) Invalid id 1599954392 specified for instance
(12:21:29) Invalid id [1599954390] specified for lux_object_from_id
(12:21:29) Invalid id 1599954390 specified for instance
(12:21:29) Invalid id [1599954391] specified for lux_object_from_id
(12:21:29) Invalid id 1599954391 specified for instance
(12:21:29) Invalid id [1599954392] specified for lux_object_from_id
(12:21:29) Invalid id 1599954392 specified for instance
(12:21:29) Removing empty instance "back"
(12:21:29) Removing empty instance "membrane"
(12:21:29) Removing empty instance "basket"
(12:21:29) Removing empty instance "back"
(12:21:29) Removing empty instance "membrane"
(12:21:29) Removing empty instance "basket"
(12:21:29) Removing empty instance "back"
(12:21:29) Removing empty instance "membrane"
(12:21:29) Removing empty instance "basket"
(12:21:29) Removing empty instance "back"
(12:21:29) Removing empty instance "membrane"
(12:21:29) Removing empty instance "basket"

Offline mattjgerard

  • Hero Member
  • *****
  • Posts: 1702
Re: Disappearing parts after splitting parts using Edit Geometry
« Reply #1 on: February 25, 2020, 07:29:20 am »
Yep, used to have this problem all the time, which version of Keyshot are you using?

Offline Lars

  • Newbie
  • *
  • Posts: 13
Re: Disappearing parts after splitting parts using Edit Geometry
« Reply #2 on: March 04, 2020, 06:43:57 am »
Yep, used to have this problem all the time, which version of Keyshot are you using?

You used to? Are you on version 9?
I have Keyshot 8.20.80

Offline mattjgerard

  • Hero Member
  • *****
  • Posts: 1702
Re: Disappearing parts after splitting parts using Edit Geometry
« Reply #3 on: March 04, 2020, 08:41:35 am »
Yes I'm on 9, I think this was a point fix in 8, so make sure you are on the latest version of 8. Or upgrade to 9, I can confirm this does not happen anymore in 9. I used to have problems with split surfaces actually moving, or disappearing. No longer. Somewhere along the line they fixed it. You can submit a support ticket on their support sight to get more info on it and how to fix. Updating worked for me.