Author Topic: HELP - Problem with multi-Camera animations  (Read 251 times)

0 Members and 1 Guest are viewing this topic.

Offline jinjamu

HELP - Problem with multi-Camera animations
« on: May 03, 2020, 11:01:34 pm »
Hi,
I’m using Keyshot 9 principally to create animations of underwater architectural models originally created using photogrammetry, for educational/outreach purposes.
I’ve been struggling with implementing a particular animation I need, hopefully someone can help.  My model consists of two main areas of interest connected by some seabed.  The camera animation I have in mind needs to perform an orbit around one area, then fly along the seabed to the second area, perform an orbit around that, then return to the starting point of the first area.  For the specific purpose I have in mind, the animation needs to be a continuous, unbroken, smooth loop.
Using Camera 1 creating the first orbit followed by the flight along the seabed is no problem, but I got stuck when trying to combine with the second orbit while still using Camera 1, because the Camera 1 target is still the first area of interest. I tried a couple of methods to solve:
Method 1
1.   Animate Camera 1 using Orbit followed by Transition animations, ending up with Camera 1 at the position required to start the orbit of the second area
2.   Create Camera 2 based on the end frame of Camera 1
3.   Set Camera 2 target to the centre of the frame (using the grid to guide the mouse pointer)
4.   Create a switch to Camera 2 at end of Camera 1 animation
5.   Create orbit for Camera 2 around second area of interest
This works after a fashion, however there is a risk of a jerky transition between Camera 1 and Camera 2 due to the fact that the Camera 2 target is being selected manually.
Method 2
1.   Create Camera 2 at the position required to start the orbit of area 2, setting up Camera 2 target as required
2.   Animate Camera 1 using Orbit, followed by a Path animation using the location of Camera 2 as the second Control Point
3.   Create switch to Camera 2 at end of Camera 1 animation
4.   Create orbit for Camera 2 around second area of interest
On paper this should work better than the first method, however I simply could not get the Path to work, and when I ran the animation Camera 1 ended up at totally wrong coordinates, even though when I selected Camera 2 as the second Control Point the Camera 2 coordinates were shown correctly in the coordinate list.  There must be something I am not understanding regarding how the Camera path animation works.  I also tried playing around with a very simple path to understand how this function works, but for example a simple straight path gave me a 180 degree camera twist for some reason I cannot understand.
Grateful for any suggestions cos this is driving me nuts!
Thanks in advance
John

Offline Erik Williams

Re: HELP - Problem with multi-Camera animations
« Reply #1 on: May 04, 2020, 07:10:38 am »
Hello,
There is an issue with KeyShot 9 where camera switch events disable certain animations and transitions.
We are investigating this issue now and will have it solved as soon as possible.

Thank you for your patience while we look into this.

Offline jinjamu

Re: HELP - Problem with multi-Camera animations
« Reply #2 on: May 05, 2020, 01:05:43 am »
Thanks Erik. 

To be perfectly honest I'm not sure whether the issue you mention is directly related to my problem, however I look forward to hearing back from you.

Regards,

John

Offline Niko Planke

  • Software Tester
  • Global Moderator
  • Full Member
  • *****
  • Posts: 127
  • Total likes: 3
  • QA-Lead, Luxion
Re: HELP - Problem with multi-Camera animations
« Reply #3 on: May 05, 2020, 06:54:41 am »
Hello jinjamu,

Often for more advanced camera animations its easier to create it in the CAD software if possible.

Combining multiple animations Especially Path animations can cause undesired effects since their translations and axis rotations stack up and can impact each other.
In other words if you rotate a camera 90 degrees and then add a camera path animation the 90 degree rotation of the camera is taken into account for the path. This can be seen as the red line vs. the orange control points in the Geometry view (shortcut: O)

I would always suggest to have the Geometry view open while creating Camera animations, it is a good tool to keep an overview over what happens.
You can also right click Camera control points in the geometry view to get a move widget in the geometry vie window.

I think for you the best option is to create the animation in one continuous Paths animation.
1. create Camera 1 and add the orbit animation.
2. Create Camera 2 and its Orbit animation.
3. You can now use the orbit animations to create new static cameras along the orbit.
4. You can then create new camera with a single Path animation for both areas of interest  by using the static cameras .

You should then be able to control the speed via the custom easing curve.

Alternatively: If you make sure that your Orbit animations are full 360 degrees, and avoid overlap from orbit to paths animation you may also avoid the issues you have.

I hope this works for you.


Offline jinjamu

Re: HELP - Problem with multi-Camera animations
« Reply #4 on: May 22, 2020, 10:52:58 am »
Hi Niko,
I am back after a small hiatus, seeing if i can do something about this.
Honestly I simply cannot figure out how to get even a very simple path animation to work.  For example I am trying to do the following (with NO OTHER animations set up):
1.Create Camera 1
2.Create Camera 2 in a different position
3.Select Camera 1
4.Choose Path Animation wizard
   a. Choose Camera 1...Next (the Control Point list appears)
   b. From the Camera list, select Camera 2
   c. Select "Add New Control point"...Camera 2 Position coordinates appear correctly as Control Point no. 2, exactly what I wanted
But when I run the Animation, the final position of the camera is nowhere near the coordinates of Camera 2, which are the exact same coordinates saved as Control Point 2 in the list.  And in addition the camera twists by 180 deg!
Surely this must be a software issue?  Please please can someone tell me what i am doing wrong?
Thanks!

Re: HELP - Problem with multi-Camera animations
« Reply #5 on: June 09, 2020, 09:38:51 pm »
sketch import for a fly thru a development was my project and i sure scared my client when i could not control the camera paths. yup sounds like what i was racking my brain about for two weeks. even keyshot support had a time of it. in the end i was only able to deliver still animations to my client. i must say the light control and the materials look fantastic and the rendering were quick enough to allow me to switch to still shots in the last minute. i used i movie to give it some movement.

i would love to work with keyshot as it is intuitive to use. i am wondering when we can find solutions with the spin and crapshoot camera ghost path problems
please help.

Offline Eugen Fetsch

Re: HELP - Problem with multi-Camera animations
« Reply #6 on: June 10, 2020, 12:56:25 am »
Hey Valentin,

I see KeyShot more as a render engine, like VRay, Octane, Cycles, etc. If I need to solve an animation task that is impossible in KS, I simply do it outside od KS. In this case, I would export the scene to Blender, do the camera animation there, export the camera through Alembic or FBX to KS and render the job there.

Hope that helps in the future somehow.
Cheers