Author Topic: KS9 hangs while forever scrolling progress on "Finishing" after render complete.  (Read 3906 times)

0 Members and 1 Guest are viewing this topic.

Offline Aeonjoey

Anyone else having this issue or know how to fix?
I usually send all renders to our network rendering, but when it's swamped, I'll try to render locally. about 3/5 times, it'll finish rendering, and I'll click the green check button - and then It'll popdown a progress bar that says "Finishing" and this bar scrolls up to 100% over and over forever, and keyshot semi-freezes. MacOS doesn't register it as 'not responding' and you can reposition windows, all menus are grayed out like a dialog is open somewhere but there isn't anything. buttons click but nothing happens. It's happening on a daily basis now. I've reinstalled and it keeps happening.

MacOS Catalina, KS 9.3

Offline Berube

Hola,

Yes. I ran into this after completing animation renders. The bug was reporter and documented.
Meanwhile, try to use to exit the window instead of pressing the green check.

Hope this helps!

-Berube
www.johnberube.com

Offline DerekCicero

We have marked this for QA investigation. Will update when I have more info.

Offline andy.engelkemier

That sounds like the denoise process to me. Turn denoise off and it should go away.
It does seem like it takes longer than it should, but I was attributing the added time to rendering a 5k image on my end. Although, other denoising I'm doing still only takes a few seconds, so perhaps there's something wrong.

Offline Aeonjoey

Thanks Berube and andy.engelkemier!! both of those suggestions work - I'm hooked on denoise though like crack, lol - lately i seems to get best results using the queue and then the 'process queue' button, the render windows close themselves adn that solves it too.

Offline andy.engelkemier

I'm just curious. Do your files seem to take an abnormal amount of time to save? Like, just file save, or saveAs? And does that suddenly get MUCH faster if you disable GPU effects in preferences?
I'm just trying to link some possible things together, and I have a feeling that might be the case.

If you have time, do a test. Open up one of your working files that say, over 100MB. Pause the render, then save a scene and time how long it takes keyshot to respond again. Then disable GPU effects, restart keyshot (you'll lose denoise). And repeat the same thing. Pause, save the file and see how long it takes to respond.
After you do that, turn GPU effects back on, then restart keyshot again, otherwise you won't have access to GPU rendering.

If you Also have this issue, it might help Luxion find what went wrong in some of the recent versions.

GPU is Definitely not without bugs. Tracking them down While you work though? Not many people have time for that. Lately I've been having some crazy issues like multimaterials mysteriously changing materials after saving and reopening. I'll get a random GPU failure here and there as well, and it doesn't seem to be for any particular reason. I'll keep everything the same as far as what's open, restart keyshot, and it's perfectly fine. Too bad it takes me just over a minute to save my current file.