Bump maps not appearing after render upgrade from Keyshot 8 to 9

Started by annekahn, July 22, 2020, 03:57:42 PM

Previous topic - Next topic

0 Members and 1 Guest are viewing this topic.


Hey hey!

I'm running into some issues upgrading from Keyshot 8 to 9 and I'm wondering if anyone else has been having similar problems. I open my files, light my scene, and hit render. Every single time our render is kicked through our farm I'm getting different lighting and no bump maps. This problem isn't just limited to one file. This is showing up in every single file I open in Keyshot 9. Troubleshooting I've done:

-I've checked my settings to make sure everything is identical from 8 to 9
-I've imported my scene into a brand new file and I get the same issues



May you share your ks8settings.xml and ks9settings.xml, so we can check to see the differences. I guess there are some differences in the preferences e.g. folder path.


Thank you for getting back to me so quickly!
I'm excited to hear what you find.


So, I compared both ...settings.xml-files. You're working with the default resource path with the default location to C:/Users/Public/Documents/KeyShot 8 and C:/Users/Public/Documents/KeyShot 9 -> means KeyShot 9 is not using the same materials and textures like KeyShot 8.

I might be helpful to copy the textures folder from C:/Users/Public/Documents/KeyShot 8 to C:/Users/Public/Documents/KeyShot 9.

KeyShot 9 should open a warning dialog if you load an old scene but missing some files like textures, etc.

There's also a way to use the migration tool to convert the KS8 resources to KS9.

Or maybe you can create a KeyShot 8 scene with a dummy part (cube oder sphere) with a bump that works at your system (save this as KSP) and open the KSP in KeyShot 9 to see, if this will render an equal result. (or maybe publish the KS8 scene with the dummy part here as a post?!)

Good Luck

Hope that helps



Hey Marco,

I've tried out some of your suggestions. I copied the textures folder from Keyshot 8 to Keyshot 9. I sent a dummy Keyshot 8 file through our farm and the farm kicked it out with no problems.

I opened up a more complex Keyshot 9 file that was built in Keyshot 6 or 7 and ran it through our farm. The end result was a muddy render. Please see attached.

An interesting thing to note is that Keyshot 9 background renders come out just how I want them. The lighting is identical. :)

If I send the render through our farm. 17X11 72 DPI image there is a 50/50 chance that the farm will go down and if it does pump out the image it takes 20 minutes to render on five computers.

If I send the same render thorough our farm in Keyshot 8 I get what I want which is strange.



Does the render farm is also on Version 8?
Do you use interior lighting? Then you may run into a bug that's already solved.

Try to update network rendering to the current version. Or maybe send this file to Luxion's support team or your reseller. So they can try to render with the newest version to see if this would help.
Don't know where you're located. If you work in Germany, Switzerland or UK you can contact the support team of INNEO Solutions (KeyShot platinum reseller). Or start a new ticket at Luxion's help portal.