Author Topic: Help with texture pattern  (Read 845 times)

0 Members and 1 Guest are viewing this topic.

Offline superfreakkk

Help with texture pattern
« on: June 21, 2020, 08:09:09 pm »
Hi, I need some help. I create a cloth animation in cinema 4d and import to keyshot. The only whey I find to make the animation work on keyshot was bake as alembic before import to keyshot. I'm trying to put a logo in this animated cloth but the texture moves with the animation... Where I need to apply the logo texture in the material to make this  not move?

Thank you so much for the help.
Regards.

Offline Eugen Fetsch

Re: Help with texture pattern
« Reply #1 on: June 21, 2020, 11:57:45 pm »
Hi and welcome.

You need to UV unwrap the cloth and use UV mapping for the texture.

Offline superfreakkk

Re: Help with texture pattern
« Reply #2 on: June 26, 2020, 07:42:31 pm »
Hi, thank you for the reply.

When I tried to uv unwrap I receive the follow message: The unwrap tool cannot be used for parts with deforming geometry.

I bring this animation from C4D, before I bake the animation as an alembic. There's another way to do this? Thank you again.

Offline TGS808

Re: Help with texture pattern
« Reply #3 on: June 30, 2020, 09:50:33 am »
Do the UV mapping in C4D. Once the UV coordinates are set in C4D, KeyShot should recognize them when you import your animated model.

Offline Waldo

Re: Help with texture pattern
« Reply #4 on: November 12, 2020, 09:20:45 am »
I am having the same issue with bringing in UV mapped models to KS 9.3 from Maya. When importing an alembic deformation, the UV map is broken upon importing into KS. It only works as a single planner surface or Box map and not as a UV map. Does anyone know the correct export settings? Attached are the recommended alembic settings from the Autodesk/Maya. Thanks for any feedback!