'Unlimited-Realtime-Rendering' limited to 1280x923 pixels

Started by dt01rrj, November 07, 2011, 02:10:04 AM

Previous topic - Next topic

0 Members and 2 Guests are viewing this topic.


Hi  :)

I want keyshot to go fullscreen, straddling my two monitors but whenever I try to up the realtime window size it maxes out at 1280x923 (Options -> Realtime tab -> Image Settings Box -> Width/Height [I have turned off lock aspect-ratio]).  If I type anything more than those values it just jumps back to one of those max values.

I realise there is the tick box for 'Use Realtime Renderer' ('Render-Options' -> 'Render' Tab), but the results are not always exactly the same + I prefer to take quick screengrabs of the screen sometimes.

I remember being able to do it in earlier versions of Keyshot (and Hypershot) so... How do I unlock the 'Unlimited-Realtime-Rendering'

Many Thanks,

... Using Floating license Version 2.3.1 on PC


You can no longer do this due to the fact that you can resize the window interactively. However, use realtime render will give you the exact same results. All you need to do is make sure that you have detailed indirect illumination checked in the realtime tab.


Greetings Thomas,

Many thanks for your reply; the feature to make the window bigger than your monitor was a very useful 'workaround' to getting slightly better than screengrab-renderings - a shame its gone.

I didn't realise that the "Detailed indirect illumination" needed to be on for the "Use Realtime Renderer" to work - Many Thanks :) [... that's why my "Use Realtime Renderer" renderings never looked like the actual onscreen-realtime-rendering ... Unfortunately I've set up my scenes now as I want them (plus, turning on indirect illumination causes it to take a considerably longer time to render)

... any plans to have another tickbox "Use Realtime Renderer (no indirect illumination)" ?

Many Thanks,



Quote from: dt01rrj on November 07, 2011, 02:10:04 AM

I realise there is the tick box for 'Use Realtime Renderer' ('Render-Options' -> 'Render' Tab)

Where is this setting I cant find it. And in the manual under realtime render mode it gives me 404 error.
Thanks in advance, I realize this is an old thread, I hope someone replies.


Under render options you can select either maximum time or maximum number of samples. Both of these options will use the realtime renderer.


Thanks very much for the answer!

This may be a stupid question but does the resolution affect the quality of the realtime render? I mean if I render in for example 3000x3000 do I hace to wait longer than if I render in 1000x1000 to get the same quality with realtime render?

Thanks a lot for the help


Yes, you do. In order to get the same quality the realtime render mode will take 9 times as long when you use max time.


I, too, remember when we could set the real time render window larger than our monitor resolution.  A co-worker of mine misses that functionality terribly. Although you couldn't see the entire rendering, you could easily monitor how it was rezzing up on at least a portion of it.

These days we often drag open the real time render view across two monitors, sometimes rotating one of the monitors to maximize render size based on desired aspect ratio. We're seriously considering a 4-monitor set up to increase our realtime view even further. It's just much more intuitive and efficient to see the realtime rez-up and grab screen shots when we want.

How's this for a idea?  It'd be nice if we could select/set-up a status window or porthole to monitor what's happening in larger background renderings using realtime settings. This porthole would show current rez status of a smaller area of the overall rendering. Optimally, we'd also be able to pan the porthole  around to different parts of the larger rendering if desired.


Will Gibbons

Sorry to be digging up an old posting. I'm attempting to do a realtime rendering and am also restricted to 1924X981 via the 'settings' dialogue box. I need to produce larger renderings in the 3K range and would like to know how to achieve this in Keyshot 4.

I read the above questions and answers and have 'Global Illumination' enabled (peviously detailed indirect illumination) and still can't get my resolution high enough. Also, resizing the window via dragging does not work in my case.

Any help?



You set the final output resolution in the render settings.