<SOLVED>Multi-Materials set in Studios keep defaulting to wrong settings

Started by Aeonjoey, January 15, 2021, 01:49:12 AM

Previous topic - Next topic

0 Members and 1 Guest are viewing this topic.


Hey there, I don't understand what is going on here, but I have one model set, and 4 multi-materials, I've set up 4 studios, each with a different combination of multilateral settings, the checkbox is checked etc.
When I send to render or to queue for network render, it all works great.
If I close and re-open the file, ALL of the multi-material settings are wrong.
If I set one of the studios to the right combination, and move to the next to set it - the first one I set changes to what the second studio is using.
So the studios aren't keeping their multi-materials settings.
It's like Wack-a-mole, I'll click a different studio, and the settings are always lost.

Solved - a coworker told me to try un-checking the Multi-Material box on each studio with the issue, saving, closing, reopening and set the multi-materials over again, save, reopen and it worked.


We've had troubles like that before, and for a while we just avoided using multi-materials because we couldn't figure out why they were so wonky. Sometimes textures were messing up when submitting renders, sometimes this happened like you describe, and we even had some of the materials just plain disappear from within the multi-material. Things like that always happen Right in the middle of some sort of rush, so they don't get reported, because when I go back to it after the project is over, I can't repeat it.

They seem Much better in the last couple versions. Jury is still out on KS10 though. And I Don't think I get problems at all if I don't use library, or already existing, materials. So it makes me wonder if some of the "random" issues are a result of materials coming from a different version of keyshot. Very difficult to test.
The problem you describe is especially frustrating if you have like 15 different multimaterials with a dozen materials in them each. It becomes annoying to figure out the issue.

Thanks for posting a reply on fixing that though. If that happens to us, we'll give it a try.