Author Topic: Animation no longer works  (Read 2495 times)

0 Members and 1 Guest are viewing this topic.

Offline germannick

Animation no longer works
« on: February 25, 2021, 11:52:18 pm »
For the last few years, I created many complex animations with Keyshot. Now with the latest KS 10 update (10.1.80), I can no longer make the most simple animations.
I attached a representational test file to show the dilemma.No matter what I adjust, the three objects in the attached reference file, should rotate horizontally 90° around the cube... but they continue to rotate around their own center.
Using linked animation, animting the group together... all does not make a difference.
Another ussue I found is the fact that I delete a (linked) animation but the model still playes the animation afterwards. When I save, close and reopen the file, the deleted animation is back and and the linked animation is split into single animations but still acting as one....
What is going on?

« Last Edit: February 26, 2021, 04:21:46 am by germannick »

Offline germannick

Re: Animation no longer works
« Reply #1 on: February 26, 2021, 01:33:17 am »
I forgot to mention that linked nimations are no longer linked to each other AFTER the file was saved, closed and reopened. WTHeck? Luxion has alot of fixing to do

Offline tbroen

Re: Animation no longer works
« Reply #2 on: March 14, 2021, 04:45:19 am »
I've experienced the exact same problem, and didn't find a workable solution.
The only way I could finish my animations was to go back into my modelling software (In my case Solidworks) and delete all components other than the ones that had errors. Then I had to re-import those objects into my scene again to reposition and replace the parts that didn't animate right. For some reason that worked - even though it was the exact same objects. I imagine something goes wrong in the scene tree hierarchy that messes with the origins etc.


Offline Creta 3D

Re: Animation no longer works
« Reply #3 on: April 05, 2021, 03:33:00 am »
Hi there,

Has this issue been solved in version 10.1.82? I´m planning to buy the Pro version but this is a pretty nasty bug IMO.

I would greatly appreciate if someone could provide an update on this.


Offline INNEO_MWo

  • Hero Member
  • *****
  • Posts: 1327
  • Total likes: 85
  • Senior Technical Consultant @ INNEO (Germany)
    • german KeyShot page from INNEO Solutions
Re: Animation no longer works
« Reply #4 on: April 05, 2021, 09:27:29 pm »
A customer had a similar problem. This issue came with importing Inventor assemblies directly and was solved by using the step format.