Facing problems with all animations including faded objects.

Started by tbroen, March 14, 2021, 04:33:52 AM

Previous topic - Next topic

0 Members and 1 Guest are viewing this topic.


I've been facing an issue where objects that are faded to 0% opacity in animations, still affect the scene in various ways - Both excluding shadows in some areas and effecting the surface of the remaining objects in the scene (The ones that are not faded to 0%). Spotted it after rendering a 3000 frame animation with custom controls each frame was about 5 minutes per frame - So that was a bummer.

Does anybody have a workaround to get this to work - Right now I'm in the process of hiding and showing those objects manually while i render everything again.

To show the problem im having - see the attached images. I've added a .ksp package as well in case somebody want to replicate if they're experiencing the same issues.

I've inverted some of the images so the problem is very clear to see.



Hi Thomas

Instead of the fade animation, use a curve animation in the opacity of the material. That will solve the the ground shadows issue. As for the shadows cast on the remaining object, turn off Occlusion in the specular for that object. That's what's causing it and I don't think you need it there at all. KSP is attached.


Thank you very much TGS808
Great tip with the curve animation of the material. I didn't know that feature existed.
I'm not sure I can use it in my current situation though. I have thousands of parts in the scene I'm rendering, where I'm using this material among others. It would take a very big effort to separate the parts and apply the fading animation to the different materials - I will however use that feature much more in the future, but for scenes with fewer parts/materials.

The scene I uploaded was a test scene to try to identify what was causing the problems (Which I imagine is a bug in KS 10). - After some more testing I even find that the objects that are faded to 0% in opacity are also having a negative effect on render times (up to factor 5x), even though they are not visible and shouldn't effect the rendering at all.

The occlusion effect is primarily used to ensure i have shadows on steel materials even when the scene is "deep" so to speak. I've experienced that shadows on metallic materials are not cast very well without the occlusion effect. (see images)