Author Topic: GPU Rendered Image issue.  (Read 2202 times)

0 Members and 1 Guest are viewing this topic.

Offline brahmzxc

GPU Rendered Image issue.
« on: July 08, 2021, 07:07:11 am »
GPU Rendered Image is different( a bit noisy) than the one rendered with CPU. Is it material issue or I'm doing something wrong.
Please help because GPU rendering is faster and I don't have a fast CPU :( .

The left one is GPU rendered and right is CPU rendered image.

Offline KristofDeHulsters

Re: GPU Rendered Image issue.
« Reply #1 on: July 08, 2021, 02:08:06 pm »
It's often that the GPU will need some more samples to get to the same level of detail than the CPU. Don't ask me why, it's the Keyshot hocus pocus that happens in the background. I would just run the region rendered with GPU, see when it reaches the right quality you are going for and then render to that sample count.

Offline brahmzxc

Re: GPU Rendered Image issue.
« Reply #2 on: July 08, 2021, 11:32:58 pm »
okay so I have to select the region and where should I enter the values for Render Samples ? To see which value works fine.

Offline INNEO_MWo

  • Hero Member
  • *****
  • Posts: 1257
  • Total likes: 72
  • Senior Technical Consultant @ INNEO (Germany)
    • german KeyShot page from INNEO Solutions
Re: GPU Rendered Image issue.
« Reply #3 on: July 09, 2021, 02:31:16 am »
when you start your rendering, choose max. samples option and use that value for the entire image

Offline brahmzxc

Re: GPU Rendered Image issue.
« Reply #4 on: July 09, 2021, 07:24:06 am »
Okay thanks I will try this suggestion.

:) :)

Offline brahmzxc

Re: GPU Rendered Image issue.
« Reply #5 on: July 09, 2021, 07:59:57 am »
Also when I switch to GPU Mode it says Shader Cutaway is not supported in GPU mode.

Offline KristofDeHulsters

Re: GPU Rendered Image issue.
« Reply #6 on: July 09, 2021, 09:20:19 am »
Also when I switch to GPU Mode it says Shader Cutaway is not supported in GPU mode.

If you press H while in Keyshot you should get a HUD that constantly shoes you at what render samples you are. In order to determine how many samples I need I take the region where it's too grainy, and look at the sample count go up until it gets to result I am happy with. Then you know you should set the image to that sample amount to reach the crisp image.

In regards to the cutaway material: that's normal Keyshot has already said that the cutaway material doesn't want to work on GPU. I would for that render the actual cutaway part on the CPU while render everything else on GPU and then compile it in Photoshop.

Good luck!