Scene Api

Started by crrs, June 03, 2021, 10:25:46 PM

Previous topic - Next topic

0 Members and 1 Guest are viewing this topic.



I've just installed the SW plugin for Keyshot from:

I have followed the installation instructions displayed there. Exporting to Keyshot works. Sent to Keyshot and Update Keyshot do not. They both generate the same error message as displayed in the attached image.

I have noticed that the plugin has installed into a different folder in Program Files since I didn't modify anything during the install. The Keyshot installation is in c:\program files\keyshot. The plugin installed in c:\program files\Keyshot10. Since that seemed a bit fishy, I have copied the files from the Keyshot10 folder to c:\program files\keyshot\plugins. First time over I had copied the entire Solidworks folder from Keyshot10 folder in the c:\program files\keyshot\plugins folder but that didn't seem to make a difference. So I just copied over the contents of the Solidworks folder (c:\program files\keyshot10\plugins\solidworks.

This had some effect. As in, when I started Keyshot, it informed me that it cannot use the sceneapi_cs_wrapper.dll due to some version mismatch. Since my hand was quicker than my brain I just clicked the error messages (there were 3 I think) away and I wasn't able to have Keyshot generate them again.

I am running Solidworks Professional 2021 SP2.0, Keyshot 10.1.82[4.1.36] and the keyshot10 SW plugin downloaded from the link at the beginning of the post.

Is it possible to solve this issue?

I am not using anything complicated at this point, so not being able to update a model and having to create the scene all over isn't a hug issue. But I can definitely imagine that at some point, updating rather than starting from scratch might be a very very nice thing to have.

Thank you for your help.

Kind regards,


If the plug-in folder is moved to another location, the registry path should be changed as well. I guess that it would be easier to uninstall the plugin and re-install in the desired location. This might be faster than correcting registry with trial an error.

Just my two cents



@ Marco

Hallo Marco,

Thank you for your reply.

I honestly didn't think about the whole registry aspect to the issue. So I just uninstalled the plugin and reinstalled it directly into the keyshot folder, under plugins\solidworks.

Unfortunately this didn't make a difference at all, I still get the same error as before.




Thank you for reply.

That's the first thing I did when I got the error.