Started by jasmehar, August 09, 2021, 07:25:42 AM

Previous topic - Next topic

0 Members and 1 Guest are viewing this topic.


This is my first time posting here, I am a beginer in keyshot and currently working on a lighting project. Unfortunately, I am having so much trouble with rendering light reflections. Ill really appreciate if anyone can help please :)

this is a light, (first with light on and second with light off) and upper part is a sheet metal folded part with crinkled texture on the inside, it also has an led light on the bottom of the metal part on the inside. when I add the led light on the bottom part it doesnt give out the crinkled texture reflection that i want, for example look at the lit product, the reflection is plain whereas I want it to be textured. Can anyone please guide me how to give a crinkled texture or any similar texture to the reflection on the base and ground plane of this lamp.
Thank you :)


Try to use a displacement map instead of a bump map? It is really hard to help you out here with the information you have given. I suggest sharing the package file for someone to have a look at the scene and figure out what is wrong.


Sorry, i didnt understand what do you mean by using displacement map instead of a bump map, i havent used any map for lighting, just gave texture to the metal part.
In simple words, I need to give a crinkled texture to the light's reflection.
Yea I know its hard to understand, i am willing to share the file, but do I share it here?? sorry, first time on this group, no idea how this works.

Justin A

As Kristof stated and I posted in the Support forum if you can post your KSP it would be easier to see what setting you have and what needs to be adjusted.

You can attach it here or send it to Wetransfer send it to


Please check your mail, I have sent you the file via we transfer :)


Terrific, I'm sure Justin will be able to resolve it. If not, you can share the WeTransfer file link here and I can have a look as well. In order to give your metal that crinkled look you must've used a bump map or displacement map as this controls the microscopic height difference on the material. These microscopic differences are picked up by the HDRI and physical lights in your scene and cast shadows. That's how you achieve the crinkled look that you are going for.

The difference between Bump and Displacement map:
- Bump fakes the microscopic height differences by using color info on the map. It doesn't actually change the geometry, which is good for when you need less detail as it saves on render times.
- Displacement map actually changes the geometry which results in accurate shadows and high detail but can be a wrecking ball on your render times.


That sounds awesome! Yes I just checked, my files have been downloaded and I hope this gets resolved. I have been struggling with this for so many days.
I cannot thank you enough for helping me and educating me, I really need to learn keyshot and youtube doesnt help when it comes to these details.
Once again, thank you very much all of you :)

Justin A


We have spoken already but I will post my response here as well for future reference for others.

You will want to delete all the lights just keep one, you can have multiple lights but for what you are trying to accomplish one should do.  In the material tab you can change this to point light under type:
once you have done this you can position this close to the metallic interior.  Under the image tab there is a check box for denoise you will want to apply this and use the denoise blend slider to adjust how much denoise is being used.  The last thing to do  is go to the lighting tab and enable caustic lighting under the general lighting drop down, this will need to be adjusted but this is the most important one.  Caustic lighting is what allows the light to bounce around the scene.  all of this is in the project window located on the right side of the screen.

Here is a great video explaining how to get solid caustics:


Hi Justin, I have already sent you a mail about this but I do want to post this here as well.

I am so sorry for bothering you again, but I did everything you told me, but did not see significant changes so I thought I did something wrong therefore I tried and was able to open your file on keyshot, but unfortunately it looks exactly how I did it based on your guidance.
1st image is a snap, it looks nothing like your picture, I believe it's the difference of the keyshot versions, mine is 9 and yours is 10.
I also changed the denoise setting, which did not show a lot of difference. The little texture it has completely goes if I increase the denoise number, please see the second snap.
I am really not satisfied with this render, I also wanted it to be on the ground plane which it is not as well, Is there any other way I can get the desired result? I am really thankful to you for helping me out till now and I absolutely hate bothering you but I don't know whom else to ask.


Turn off ground reflections and you will see that your objects are indeed on the ground. The sharp reflections look like a shadow that makes it look as if its floating. I would also start by turning the light intensity way down, and check your render presets that you are using product.

Another option is to start over in a new scene./. I have had this happen a couple times where some setting somewhere goes way out of whack and if I just start from scratch with a new scene that can help trouble shoot some things to make sure its not a glitch in the KS file itself.