Author Topic: Save nag gone after render  (Read 831 times)

0 Members and 1 Guest are viewing this topic.

Offline Chris McSweyn

Save nag gone after render
« on: October 06, 2021, 04:04:34 pm »
It seems that if you forget to save before rendering and then you render, when you close, it won't nag but it will just close without saving changes. It's easy to say, "just save before you render" but it's pretty frustrating to lose your changes. Now you either need to completely, accurately recreate your changes to match your renderings, or make new changes and re-render.

Offline Erik Williams

Re: Save nag gone after render
« Reply #1 on: October 07, 2021, 04:34:47 am »
Hello Chris,
What version of KeyShot are you currently using and what Operating System are you using?
In KeyShot 8, 9 and 10 you will receive a message asking if you would like to Save, Discard, or Cancel when closing KeyShot if there is anything shown in your Real-Time View.

You may have disabled the pop-up. To clear any cached data, you can delete the KSSettings.xml file in your Documents folder.

Let us know if that works for you.


Best Regards,

Erik Williams
Luxion Customer Support

Offline Chris McSweyn

Re: Save nag gone after render
« Reply #2 on: October 07, 2021, 08:15:30 am »
Erik,
I'm on 10.2.113 Pro Windows 10
So... I did a bit more investigation because I do get the pop up but it turns out that it's after queue processing that there is no save nag. If I makes any changes, set a render queue, process queue and then close without saving, Keyshot will just close. All changes made will be lost.
« Last Edit: October 07, 2021, 08:59:22 am by Chris McSweyn »

Offline Erik Williams

Re: Save nag gone after render
« Reply #3 on: October 08, 2021, 04:12:34 am »
Hello Chris,

This is the first I've heard of this and so far have been unable to reproduce it.
If you could, please provide us with a detailed step-by-step guide as to what you do before closing KeyShot:
  • Do you edit the item first?
  • How many items are in the queue?
  • What are your render settings?
  • Do your renders include studios?
  • etc.

Best Regards,

Erik Williams
Luxion Customer Support

Offline Chris McSweyn

Re: Save nag gone after render
« Reply #4 on: October 08, 2021, 07:32:41 am »
I just did the following:
Opened an existing bip (previously created with Solidworks Plugin)
Moved 1 of 2 active Model Sets
Created a Studio
Added the Studio to queue (only 1 studio in queue)
Process Queue
After render is complete close program with "X"
No save nag, program closes without saving

I did the same thing with Active Model Sets instead of Studios and no nag, program closes without saving.

Render Settings:
Name + Active Studio _ Separator
5000px - 3750px
Clown Pass
Max Time: 30seconds

Next I opened the same bip that did not save the changes
Moved the same active model set
Rendered without the queue
Closed program with the "X"
Nag popped up, program didn't close.

It seems to me that the folder creation in the Queue Processing is tricking Keyshot into thinking it saved when it actually rendered.
 

Offline mattjgerard

Re: Save nag gone after render
« Reply #5 on: October 08, 2021, 07:50:14 am »
Lots of apps are moving to the "save in the background" method, which would predicate a lot of this problem. Been my request for a long time to just have KS save in the background automatically. I can't really think of any time using Cinema4D where it did an autosave and it messed me up somehow. Final Cut Pro has been doing this for years, you still get all the undo levels, but once you make a change, its saved. Web apps do it, google apps save automatically, lets get on the wagon and get that implemented here too.

Offline Erik Williams

Re: Save nag gone after render
« Reply #6 on: October 13, 2021, 05:30:08 am »
Ah, thank you for clarifying.

You are correct, when rendering a studio through the queue users are not given the option to save before closing.
Thank you for bringing this to our attention. I have reported this issue to our developers and they will have this addressed as soon as possible.

Thank you again for letting us know, Chris.
If you have any other questions or problems with the platform, please contact our team at [email protected].


Best Regards,

Erik Williams
Luxion Customer Support

Offline Chris McSweyn

Re: Save nag gone after render
« Reply #7 on: October 14, 2021, 03:44:21 pm »
Thank you Erik