Author Topic: Shadows still present after fading objects  (Read 1038 times)

0 Members and 1 Guest are viewing this topic.

Offline eggciting

Shadows still present after fading objects
« on: February 26, 2022, 12:47:40 pm »
This is extremely frustrating. I have faded objects from my scene and I can still see the shadows of those objects. How can I get rid of it or turn off shadows entirely???

Offline eggciting

Re: Shadows still present after fading objects
« Reply #1 on: February 27, 2022, 09:42:41 pm »
Shadows are there only when using GPU mode. Can someone help me?
In my animation, the first 30 frames or so take a few min or so each
As the frames go on, it takes exponentially longer. Frame 31 would take hours, frame 32 would take overnight, frame 33 would take 24hrs. This is all on CPU mode.

AMD Ryzen 9 5950x 16 core 3.4ghz, 32gb ram, RTX 5000

The model is simple with everything set to defaults.

Offline TGS808

Re: Shadows still present after fading objects
« Reply #2 on: February 27, 2022, 10:04:12 pm »
If the model is simple, instead of the fade animation on the objects, try using a curve fade animation node in the opacity of the material.

Offline JackyK

Re: Shadows still present after fading objects
« Reply #3 on: February 27, 2022, 11:24:15 pm »
Hey there,

I've had this issue for a while now too, and wrote to Luxion about it when KS10 came out.
Check out my post below, where I've attached a screenshot of the Email.
Spoiler, it didn't solve my problem ;)

https://luxion.freshdesk.com/support/discussions/topics/60000406903

Offline richardfunnell

Re: Shadows still present after fading objects
« Reply #4 on: February 28, 2022, 06:41:48 am »
Is this something you feel comfortable compositing in After Effects or DaVinci Resolve?

Fade animations can be problematic and in my experience add to render time (just like in your case). It may be easier and faster to render two versions and control the fade in post.

Offline theAVator

Re: Shadows still present after fading objects
« Reply #5 on: February 28, 2022, 07:59:02 am »
This is extremely frustrating. I have faded objects from my scene and I can still see the shadows of those objects. How can I get rid of it or turn off shadows entirely???

To get rid of the shadows entirely, just deselect Ground Shadows in your Environment Panel.

What do your render settings look like?
Are you rendering frames, or straight to a video file and what format if so? are your frames set to PNG or JPEG or something else?
Do you have a ground plane in the scene or other geometry under the fading object?
Is there an HDRI or backplate or color background?

Any other details you could provide on the scene composition and output settings would greatly help in finding a solution or workaround.

Offline RRIS

  • Sr. Member
  • ****
  • Posts: 394
  • Total likes: 55
  • Renze Rispens - industrial designer
Re: Shadows still present after fading objects
« Reply #6 on: March 01, 2022, 03:16:57 am »
Long discussion about it here as well:

https://forum.keyshot.com/index.php?topic=27381.0