Author Topic: Render queue only uses 1 cpu-core of 2  (Read 3374 times)

0 Members and 1 Guest are viewing this topic.

Offline BachManiac

Render queue only uses 1 cpu-core of 2
« on: August 17, 2011, 10:04:39 pm »
Hi!

during batch-rendering there are always two ks-processes running. one is the "rendering process" (which uses the most memory), and the other coordinates the queue, so I cannot kill the second process.

KS only uses 1 core of my dualcore during batch-rendering, becaus the second keyshot-process uses the other core.

I already changed the realtime-rendertime to 30s but during batch-rendering the second ks-process uses one core permanently.

so batch-rendering is only half as fast!

I have to set the process priority of the keyshot process to "low", then the "batchrendering" keyshot-process gets both cpu's.

This should be fixed in the future I think.

« Last Edit: August 17, 2011, 10:07:53 pm by BachManiac »

Offline DonChunior

Re: Render queue only uses 1 cpu-core of 2
« Reply #1 on: December 12, 2011, 04:13:16 am »
Has this issue already been fixed?

Regards, DonChunior

Offline PhilippeV8

Re: Render queue only uses 1 cpu-core of 2
« Reply #2 on: December 13, 2011, 03:55:49 am »
I had no idea of this issue !

Thnx for pointing it out.  In my version of KS2.2 it's still there.

Offline PhilippeV8

Re: Render queue only uses 1 cpu-core of 2
« Reply #3 on: December 13, 2011, 04:01:00 am »
Silly though ... I set KS main program to priority low.  The render window stays at normal.
After the first render is done, the new render window gets priority low as well ... so in fact it's no real help unless you're monitoring it and setting the render window to normal with each new render ...