Author Topic: Environment moves in my animation  (Read 3516 times)

0 Members and 1 Guest are viewing this topic.

Offline JAKiii

Environment moves in my animation
« on: February 14, 2012, 01:50:48 pm »
So here's a question: I ran this animation test using an aircraft hanger environment and no backplate.  The animation is a short camera move, and as the camera swings around, the ground plane in the environment moves underneath the model.  Is there a way to prevent this?  Or is this a limitation of lighting with environments?

Thanks for any help,
Jamie


Offline KeyShot

Re: Environment moves in my animation
« Reply #1 on: February 15, 2012, 01:34:01 am »
Check 'flatten ground' in the environment tab.

Offline JAKiii

Re: Environment moves in my animation
« Reply #2 on: February 15, 2012, 09:19:50 am »
Flatten Ground is no good, it distorts the environment and only works if I use a backplate.

Before and after flattening ground, see below:
« Last Edit: February 15, 2012, 09:21:35 am by JAKiii »

Offline PhilippeV8

Re: Environment moves in my animation
« Reply #3 on: February 15, 2012, 12:17:39 pm »
what if you increase environement height ?

Love the plane by the way !  Good textures.

Offline JAKiii

Re: Environment moves in my animation
« Reply #4 on: February 15, 2012, 12:26:39 pm »
Good idea, raising the environment height worked to some extent, but the floor is still distorted and the black circle is still a problem.

Offline PhilippeV8

Re: Environment moves in my animation
« Reply #5 on: February 15, 2012, 12:40:43 pm »
Ok, from now I can't help anymore.

So, Mr Keyshot folks .. how to get this perfect ?

I wonder ... it looks as though the HDRI, which is projected on a sphere; when enabling "flatten ground" gets a flat spot at the bottom and the texture of the HDRI is stretched.  There should be a better projection when using this option.  Can it be done ?