Author Topic: 3.1.48 Bugs  (Read 4353 times)

0 Members and 1 Guest are viewing this topic.

Offline Pasu

  • Newbie
  • *
  • Posts: 17
3.1.48 Bugs
« on: March 22, 2012, 07:01:14 pm »
A few things I've noticed:

Undo hotkey (ctrl-z)  resets camera view, and doesn't undo the last operation, eg hide or material change.  Multiple undo's in a row sometimes are able to actually undo last operation
                  -the camrea view reset also resets camera pivot point

When I add a render to the local queue- the realtime view doesn't update until the queue is processed.  Deleting the jobs, pausing/unpausing re-enables the realtime window. 

When network rendering: the max time and max samples returns a pixelated render after just a few seconds of processing time, regardless of settings - only the classic 'advanced' returns correct results

Region rendering doesn't work over network - won't error, just processes a blank file (at least it's fast!)

Clicking on an slider used to increment a very small amount - it now moves to the nearest .2 (eg, when positioning a label)- which makes it hard to position accurately- must resort to typing in numbers again.  .015... 0.019.....021!  Got it!

Re-enable (at least as an option?) saving of renders cancelled partway through.  Sometimes I'll do a region render to check an area/setting, and cancel it once i've looked at what I need to.  It's helpful for quickly comparing settings without waiting for a whole model to res up in the realtime window. 

Even so- KS3 is neat!  Keep the new versions coming.  Thanks guys!

Offline KeyShot

  • Administrator
  • Hero Member
  • *****
  • Posts: 1235
Re: 3.1.48 Bugs
« Reply #1 on: March 23, 2012, 08:59:07 pm »
Thanks Pasu. We will take a look at these issues.

Offline ralphzoontjens

  • Newbie
  • *
  • Posts: 2
Re: 3.1.48 Bugs
« Reply #2 on: May 23, 2012, 01:38:41 am »

I'm working on an animation of a fairly large model. It's a city with several objects within it such as cars, traffic signs, benches etc. After importing with a tessellation quality reduced as far as 0.025 the file is 338 Mb.

After having imported some textures onto the ground and pavements, the screen turns black so I can't see my model any longer. When I reverted to a saved camera view, I was able to see the model again but as soon as I changed the camera it turned black. Now even the camera views don't give me anything any longer. I tried disabling the GPU, and updating my video card drivers, but to no avail. I tried disabling the textures, but this also doesn't work. Sometimes KS crashes when I try to alter a material.

Can you help me out here?

Some other things I would like to see improved:
- When importing assemblies from Catia into Keyshot, it does retain the name of each assembly and part, but not of the bodies within those parts. They are all given the name of the part that they are part of. Sometimes that takes a lot of searching in the scene tree so it would be helpful if also the name of each body is retained.
- In animations, when you rotate an object around a helper object, it takes the original coordinates of that object. So I cannot move the helper object in Keyshot and then have the animated object rotate around this new position since it will keep rotating around its original location. It would be nice to have that implemented in the next KS update.


Offline Gavrik

  • Newbie
  • *
  • Posts: 33
Re: 3.1.48 Bugs
« Reply #3 on: May 23, 2012, 02:41:49 am »
Fresnel Bug.
When a change checkbox Fresnel and change Specular sometimes it changes my texture from box map to uv.


  • Guest
Re: 3.1.48 Bugs
« Reply #4 on: May 23, 2012, 06:30:28 am »
@gravik - this has been fixed in KeyShot 3.2


  • Guest
Re: 3.1.48 Bugs
« Reply #5 on: May 23, 2012, 06:31:39 am »
@ralphzoontjens - please check out KeyShot 3.2.

As far as the CATIA import goes, can you please provide a simple example file and tell us what the name of the bodies should be.