Author Topic: Retain materials doesn't work for Rhino files.  (Read 12022 times)

0 Members and 1 Guest are viewing this topic.

Offline vanka

Retain materials doesn't work for Rhino files.
« on: February 24, 2010, 09:59:25 am »
Though "retain materials" option is marked beta I would like to inform you about the following:

I created small scene in Rhino (cube and sphere) and assigned materials (img 1).

Then I added one object (cone), saved the file, pressed open in KeyShot, checked "retain materials" and the materials shifted to the next created in Rhino object or disappeared (img 2).

This thing is really very incovinient. Half of time I spend reassigning materials after any change or addition of objects.

Please, fix the bug. It will save a lot of time for those who use Rhino!
« Last Edit: February 25, 2010, 01:29:32 pm by vanka »

Offline vanka

Re: Retain materials doesn't work for Rhino files.
« Reply #1 on: March 08, 2010, 11:01:24 am »
Hey, what's going on?

I've mentioned a real problem with Rhino "retain materials" and no word from KeyShot developpers for 2 weeks!

Are you going to fix it or do you think it's not important for Rhino users?

guest84672

  • Guest
Re: Retain materials doesn't work for Rhino files.
« Reply #2 on: March 08, 2010, 01:38:56 pm »
We are revisiting the whole "retain material" subject for version 2. It will be much more than what is currently implemented.

Offline vanka

Re: Retain materials doesn't work for Rhino files.
« Reply #3 on: March 09, 2010, 08:28:44 am »
Thanks for the reply!

And when 2.0 is going to be released?

guest84672

  • Guest
Re: Retain materials doesn't work for Rhino files.
« Reply #4 on: March 09, 2010, 02:35:19 pm »
We hope to have a beta version available in April, and then shortly after that.

Offline vanka

Re: Retain materials doesn't work for Rhino files.
« Reply #5 on: June 10, 2010, 07:46:51 am »
Thanks for good work (I mean KeyShot 2)!

But nothing changed with retain materials for Rhino files (the problem mentioned in the topic).
This is very sad :(

Are going to refine it?

guest84672

  • Guest
Re: Retain materials doesn't work for Rhino files.
« Reply #6 on: June 10, 2010, 08:11:33 am »
Can you send me the example file?

Thanks,Thomas

Offline vanka

Re: Retain materials doesn't work for Rhino files.
« Reply #7 on: June 10, 2010, 08:51:38 am »
Here are 2 files. Cube and sphere in the first, the same plus cone in the second.

Offline vanka

Re: Retain materials doesn't work for Rhino files.
« Reply #8 on: June 16, 2010, 01:09:28 pm »
Hi!
A week has passed, but no word from KeyShot team :(
Are you going to fix the problem?


Offline ben10

Re: Retain materials doesn't work for Rhino files.
« Reply #9 on: July 30, 2010, 08:55:20 am »
it also doesn't retain any texture maps from direct render export inside rhino. Hypershot can do this before with all materials in the toolbar. Hope to add this toolbar soon

guest84672

  • Guest
Re: Retain materials doesn't work for Rhino files.
« Reply #10 on: July 31, 2010, 06:52:12 am »
I am not sure I understand?

Offline ben10

Re: Retain materials doesn't work for Rhino files.
« Reply #11 on: August 01, 2010, 08:20:00 am »
if direct render inside rhino  the default material will be the layer colors...but if you import the .3dm files in keyshot standalone the texture maps works...why is it like this? before in hypershot it recognizes materials made inside rhino and hitting render button...it also has toolbar for basic materials to paint into the objects

guest84672

  • Guest
Re: Retain materials doesn't work for Rhino files.
« Reply #12 on: August 01, 2010, 08:42:27 am »
I still don't understand the first part of your question.


Offline vanka

Re: Retain materials doesn't work for Rhino files.
« Reply #13 on: October 01, 2010, 11:57:41 am »
I can't believt it, but it looks like retain materials works now for Rhino files!
I'll continue to check it, but thanks a lot in any case!!!

guest84672

  • Guest
Re: Retain materials doesn't work for Rhino files.
« Reply #14 on: October 01, 2010, 03:51:53 pm »
It is. We found why it wasn't working reliably before. Reworked the importer, and now you get layer names as well!