Proe5 / creo elements plugin will not start

Started by nielsc, July 31, 2013, 01:33:49 AM

Previous topic - Next topic

0 Members and 1 Guest are viewing this topic.



I cannot get the ProE plug-in (new 2.2) to work on my ProE 5.0 / Creo elements M170 runing 64bit

I'm getting an application unknown error and it does not start - see attachment for error

This is not working on my production setup and just to be sure that the ProE installation is ok, I have made
a new clean ProE installation on a clean Windows7 but that does not work either

Any ideas?

Best regards


Try installing/updating the components from Visual C++(2005,2008,2010). We are working on improving this.


Assume this is the Visual Basic API or Pro/Toolkit that are part of ProE installation????

It was installed on my production installation but not on the clean installation - tried to install
but did not helt

Just checking the installation files of the plug-in: the file keyshot4_proe5_plugin.dll seems relatively old.
It's is dated 23-05-2013 13.07 size 15.1MB
Could this be too old??

The error message below indicates that there is a mismatch on the proe version as my
application for Edrawings show the version 29 but for Keyshot is is unknown

Application 0: eDrawings
Exec path: C:\PTC\PROE5_64\x86e_win64\obj\proeconnector.dll
Text path: R:\SETTINGS\eDrawings2013\eDrawingsProE
Version 29 - 2010370
Application is running.

Application 1: KeyShot4
Exec path: C:\PTC\KeyShot4\Plugins\ProEngineer5.064bit\keyshot4_proe5_plugin.dll
Text path: C:\PTC\KeyShot4\Plugins\ProEngineer5.064bit
Version unknown
Application is not running.

BR NielsC


Tried to install Microsoft Visual C++ 2012 Redistributable (x64) - 11.0.60610 as the attempt
to install version 2010 gave the message that newer files were present

Still no luck


Hey Nielsc,
had the same Problem a month ago.

I ask the IT department to reinstall Keyshot and the plugin. It was realy importent that they did it with the Administrator Account

Also we installed the following runtime library:

Best Regards and good luck!


 :D :D

Thank you that worked.

It must be the Run As Administrator that did the job as i have tried to install
the additional files before

Don' know if wrong but i had to add the menu points manually



I've tried it all, and it's still not working for me.

Installed VisualC++ and .NET
Reinstalled both keyshot and plug-in as administrator.

Does anybody know what could be wrong?