KeyShot Forum

Technical discussions => Animation => Topic started by: zooropa on September 16, 2019, 02:38:10 am

Title: Animation, invisible model from beginning till specific frame
Post by: zooropa on September 16, 2019, 02:38:10 am
Hi. I am trying to find out how to make a layer to appear at certain frame.
The fading animation effect does not work in this case. I need to be invisible the first seconds without transitioning.
I tried to use a Fade effect and leave it 0% from and 0% too till certain frame. Then it the subsequent frame I added another Fade effect  from 0% to 100%.
It does not work: After I add the Fade effect from the beginning with both from and to in 0% ...it seems the other fade effect stop working (the one should work to make it appear).

In another words: I would like the red cube only shows when the orange one fades out.


Title: Re: Animation, invisible model from beginning till specific frame
Post by: Eric Summers on September 16, 2019, 07:10:40 am
This is the way I've done it in the past:
Create a fade animation and have it fade from 100% to 0%. The length of time doesn't matter much, you can make it as short as you want. Move the work area start marker after this fade. Then you should be able to do your fade from 0 to 100% whenever you want. I think this is a bug they plan to address in a future release, perhaps in 9. I seem to remember a post about this, but I can't find it right now.
Title: Re: Animation, invisible model from beginning till specific frame
Post by: germannick on September 24, 2019, 05:43:34 am
Just push your fades from 100% to 0% to the beginning of your animation and set your start of the animation work area  a few frames later. When you render your animation, you select render WORK ARE or FRAME RANGE what ever works for you best.
Title: Re: Animation, invisible model from beginning till specific frame
Post by: zooropa on September 30, 2019, 12:08:49 am
thanks that worked for me!
Title: Re: Animation, invisible model from beginning till specific frame
Post by: sleby on October 14, 2019, 11:36:56 pm
Looks like a bug, 0 to 0 should work. Try setting 0 to 0 first then all the other fades.