KeyShot Forum

Technical discussions => General discussion => Topic started by: kyng on October 10, 2019, 12:37:52 pm

Title: Error message when open Solidworks file
Post by: kyng on October 10, 2019, 12:37:52 pm
Hi, I have a question . I have a stp file I open it in SW and save as SW file . When I open it in KS I get this message. Can someone tell me what is missing ? Thanks!
Title: Re: Error message when open Solidworks file
Post by: Eric Summers on October 10, 2019, 01:50:04 pm
Are you importing it from inside KeyShot? If so, try using the plugin and sending it to KeyShot. I try to only use the plugin, sometimes I get errors when importing from inside KS.
Title: Re: Error message when open Solidworks file
Post by: kyng on October 11, 2019, 09:00:50 am
Hi Eric, Yes I usually run KS and import my models from there . Are you talking about the plugin that you can install it so you can import directly from SW? I'll check that out . Thanks!
Title: Re: Error message when open Solidworks file
Post by: kyng on October 11, 2019, 09:07:45 am
Yes Eric. I just installed the plugin and it worked! Thank you!
Title: Re: Error message when open Solidworks file
Post by: Eric Summers on October 11, 2019, 09:26:19 am
You're welcome! Glad that worked for you.
Title: Re: Error message when open Solidworks file
Post by: RRIS on October 14, 2019, 11:57:47 pm
Yes Eric. I just installed the plugin and it worked! Thank you!

In our office we just switched to using parasolid x_t files for exchange to Keyshot. They update in Keyshot just fine and have less issues than STEP files (where you might sometimes get untrimmed surfaces).
For some weird reason my own Solidworks files would import just fine, but anything my manager would make would simply not import at all. I'm the only one using Keyshot intensively, so I got the plugin for my own sanity..