KeyShot Forum

Technical discussions => General discussion => Topic started by: Higuchi on April 04, 2021, 06:16:51 pm

Title: exported .usdz (USDZ) does not work well on iOS devices
Post by: Higuchi on April 04, 2021, 06:16:51 pm
Hi there,

Do you usually succeed in exporting .usdz and playing it on iPhone? I couldn't make it with specific model, though I've tried it many times with different conditions. My iPhone can recognize .usdz as AR data and automatically boot Quick Look application, but it couldn't end up successfully open it. Since I can properly use it with simple model and material, the cause of fail seems to be in the model, I guess. Can anyone come up with the factors which I have to confirm?

My conditions are
- .usdz file is 6.2MB (I think it's not too large to play)
- I've tried it on iPhoneIX and latest iPadpro with latest iOS
- The consequence doesn't improve, though I remove any complex texture data
Title: Re: exported .usdz (USDZ) does not work well on iOS devices
Post by: Higuchi on April 05, 2021, 06:59:00 pm
*update

I've found out the cause of the problem. Original 3D data is made of IGES, then I converted to other common format on Solidworks. In the end, as far as I experiment, only IGES does not work well on Keyshot. Other than USDZ issue, Keyshot cannot seem to properly display IGES data on time, possibly it might happen this data.

As a result
-.sldpart ---> Success
-.x_t ---> Success
-.step ---> Success
-.iges ---> Failure

Anyway, I managed to resolve this problem by converting 3D data. I hope it would be helpful for you.
Title: Re: exported .usdz (USDZ) does not work well on iOS devices
Post by: INNEO_MWo on April 05, 2021, 09:17:13 pm
Hello Ryosuke.

Thank you for sharing your test results and solution. This might help other users to solve this issue.
I am wondering about this, that the IGES format causes trouble.

Hope that Luxion’s devs look into this.


CheerEO
Marco
Title: Re: exported .usdz (USDZ) does not work well on iOS devices
Post by: ddolezal on April 06, 2021, 10:54:49 pm
Hello,


I hope it is ok to append my question to this thread:


We also have problems exporting to USDZ, because the USDZ always contains the baseplane of the keyshot file, which is in our cas 1500 x1500 cm.
When we have a model like a 0,33l Aluminium can, this looks quite weird after the model is loaded on the iphone.
Are there any possibilities to exclude the baseplane in the USDZ-Export, that only the can is included and displayed in a proper size/scaling when the USDZ is "i-opened"?


Thanks,
Dieter

Title: Re: exported .usdz (USDZ) does not work well on iOS devices
Post by: Higuchi on April 08, 2021, 06:09:36 pm
Hi Dieter,

In my experiences, I've never faced what you mentioned. I know there are still many issues about USDZ and AR on Keyshot, but the scale is always proper on AR. Hope it will be a bit reference for you.
Title: Re: exported .usdz (USDZ) does not work well on iOS devices
Post by: Higuchi on April 08, 2021, 06:11:50 pm
My pleasure. Hope we Keyshot users can contribute the update of Keyshot!

Hello Ryosuke.

Thank you for sharing your test results and solution. This might help other users to solve this issue.
I am wondering about this, that the IGES format causes trouble.

Hope that Luxion’s devs look into this.


CheerEO
Marco
Title: Re: exported .usdz (USDZ) does not work well on iOS devices
Post by: Erik Williams on July 12, 2021, 02:41:06 am
Hello Ryosuke,

To get a better understanding of the issue, we would need some additional information. If you could, please send the following to [email protected] A representative will look into this further.


You can send all of this to us through our secure WeTransfer link at https://keyshot.wetransfer.com/

Thank you for your help.

Best Regards,

Erik Williams
Title: Re: exported .usdz (USDZ) does not work well on iOS devices
Post by: KristofDeHulsters on July 14, 2021, 03:16:04 pm
Wow, impressive that you figured out what was causing the issue!
Title: Re: exported .usdz (USDZ) does not work well on iOS devices
Post by: cameraman!1 on July 14, 2021, 05:12:27 pm
Wow, impressive that you figured out what was causing the issue!
Indeed! I thought this was going to be one of those cases that take a lot to get a meaningful or useful answer.