KeyShot 2.1 Step Importer is broken

Started by ukindler, October 21, 2010, 10:37:05 PM

Previous topic - Next topic

0 Members and 1 Guest are viewing this topic.



we just switched from Hypershot 1.9 to KeyShot 2.1. We have a step model that we could import into Hypershot 1.9 flaweless and that we cannot import into KeyShot 2.1 because the importer crashes. We tried the old and new step importers but both crashed.

I sent an email to (and even attached a link to the step model) but did not get any response - so I post this issue here and hope someone cares.

Regards, Uwe

Uwe Kindler
Dipl. Inf. (FH)
Software Engineering



You are correct - I just tested it and even after changing the German character it fails. We will investigate.

In the meantime you may try to import the Inventor file directly. We have enabled Inventor import for 2.1. It is still in beta, but it works. You will need to go to import and then select "all files" to be able to select the Inventor file.

Support will get in touch with you as far as the render resolution goes.


I just turned off the new importers in the preference tab and tried to import the STEP file. Worked without any problems.



Hi Thomas,

thank you for your reply.

After removing all german characters from the filename I could import the file with the old step importer like you mentioned in your last post. So the old step importer seems to work as long as there are no german characters in the filename - in this case the importer crashes.

I also tried the importer for the inventor files (*.iam). I used the *.iam file that was the base for the previous STEP export from Inventor. The KeyShot importer did not crash but in the imported geometry a lot of parts are missing. If my colleague opens the *.iam in his Inventor then there are no parts hidden.

Any things we need to take care of if we use the inventor importer? Any idea why only some parts are imported properly?


The Inventor importer is still in BETA. We know that hidden and suppressed parts still show up when being imported into KeyShot.

Can you share any Inventor models that show these issues? The will help us to debug and troubleshoot. Please send directly to



Thank you for the idea. But I don't know how really make it done.