Keyshot will not import Solidworks files

Started by KarlBakker, November 12, 2010, 11:59:39 AM

Previous topic - Next topic

0 Members and 1 Guest are viewing this topic.



Please help! When I go to import a Solidworks file into Keyshot, I get a message saying the file "does not contain 3D geometry". I have tried using the "Open" and "Import" commands in Keyshot, and I have also tried using the Solidworks Keyshot Plugin. I have tried this with a number of Solidworks files, and none of them work.

Macbook Pro 5,3; 8mb RAM
Bootcamp + Windows 7 64bit
Solidworks 2011
Keyshot 2.1
Keyshot Plugin for Solidworks


KeyShot does not support SolidWorks 2011. This is due to the fact that SolidWorks has yet to provide the API.


Although not related to the answer regarding SW11, this can happen.  Sometimes when I'm in a rush, and I have the SW10 file open, I'll accidentally try to import the ghosted out icon with the $ prefix.  Gotta be the "real" file!
Bill G


Thomas--I just checked Solidworks Support website and API's are available for Solidworks 2011.                     



Thomas--do you know of any work around I could use? Like the best Save As file format out of Solidworks, that sees multiple bodies in one part?


when will this be avail?  I need this too.


Depends largely on SW. Unfortunately this is out of our control.