NX Plugin - No geometry

Started by Magnus Skogsfjord, December 21, 2015, 02:04:57 AM

Previous topic - Next topic

0 Members and 1 Guest are viewing this topic.

Magnus Skogsfjord


I have gotten the enterprise version of KeyShot 6, in order to use NX plugin. The installation went fine, and the toolbar is present in the NX-interface, no problem there. However, when I click Render with an arbitrary model, no geometry is exported/imported. I don't get any error message. It simply opens KeyShot, but doesn't include any geometry.


  • Windows 10, updated
  • NX10, full install, version 10.0.3 (newest maintenance)
  • KeyShot6 enterprise version

What I have tried so far:

  • Reinstalled NX, KeyShot and the plugin
  • Made sure that the reference sets is set to "Model" in NX
  • Reinstalled "PVTRANS" in NX

The funny thing is, that one of my colleague tried it as well, and he got it to work flawlessly on his computer, so I guess the issue is locally on my computer, but I have no idea what could cause the problem.

Any ideas?

Magnus Skogsfjord

UPDATE: My colleague had NX10.0.2 when he tested it. When he upgraded to NX10.0.3, the same thing happened to him. So it seems that the issue is related to the latest maintenance release of NX.