Author Topic: Wrong object scaling?  (Read 6329 times)

0 Members and 1 Guest are viewing this topic.

Offline Subrosa

Wrong object scaling?
« on: January 18, 2016, 06:15:56 am »
Hey,
I create most of my models in Rhinoceros 5 and render them in Keyshot 5. I am still a student and so not a professional user of Keyshot or Rhino.

Here is my problem:
Sometimes when I import a smaller model to Keyshot (for example a object i made in Rhino measuring 50*100*60mm), the material scaling is just crazy. If I put on a material like wood or nylon fabric from the library i have to set the texture scaling to something like 0,00001 for it to look okay - which cant be normal.
Sometimes I move the camera too close to the object because it just gets "eaten up" and I can look inside it even though it looks like I am a few steps away from it.
Another thing is, that a 50mm circle made in Rhino is not really a circle in Keyshot. Its more like a 30 edged polygon.

Short story: I think keyshot handles a 100mm object exported from rhino to keyshot as if it was a 2mm object.

I tried different mappings. I tried both options when importing it (automatic scaling, keep original). Both did not work. What else could be the problem?

Thank you! :)

Offline TpwUK

Re: Wrong object scaling?
« Reply #1 on: January 18, 2016, 06:57:25 am »
Are you using render meshes from Rhino or are you importing the NURBs data directly ?

Martin

Offline Subrosa

Re: Wrong object scaling?
« Reply #2 on: January 18, 2016, 08:58:18 am »
These are my usual settings.

Since I am new to rendering and 3d modelling, I am not sure. "Keep-nurbs-data" (at the bottom) is unchecked.

I pretty much save my files as .3dm in Rhino and then drag/drop them into keyshot. Then I just check "put on ground", "center geometry", "Center camera on geometry" and sometimes I try if "automatic scaling" or "keep scaling" works better.

Offline TpwUK

Re: Wrong object scaling?
« Reply #3 on: January 18, 2016, 09:36:51 am »
Hi Subrosa, KS5 can render NURBS so bring in your model with NURBS-Daten importieren selected. This will help with the tessellation issues you are getting. Also KS5 was actually much better at handling models created in millimeters, especially the procedural shaders. Also keep in mind a unit of measurement is still just a unit in KS. Keyshot has always favoured inches, so just import the model as inches it will help when scaling the bitmapped textures. Keyshot is more about getting things to look right, i find the scaling is more important when other models are being added into the scene rather than a starting point.

So to clarify....

A cup is a cup no matter it's scale. So if you are modelling just one part or just a full model needing no additional geometry, then use inches and make it look right.

If you are importing multitudes of models from different sources using different units of scale mm/in/m etc then the scaling becomes more critical

Martin

Offline Subrosa

Re: Wrong object scaling?
« Reply #4 on: January 18, 2016, 10:08:48 am »
Hey and lots of thanks for the answer,
when importing to keyshot I can't select the unit (in, cm, mm or whatever). Where should i do that? I really don't want to start a project in Rhino using inches, since we don't use inches here.  Is it possible to work in mm and export in inches (Rhino)?

Additionaly I tried to import a file with "import nurbs data" selected. The result remains pretty much the same. I can't tell a difference in tesselation or the texture scaling issue.  :(

Here is a screenshot in Rhino, which shows, that the curves are actually smooth. Then a quick rendering in Keyshot, where the curves come out really bad...

Hoping for another idea or a tip.  :)

Offline TpwUK

Re: Wrong object scaling?
« Reply #5 on: January 18, 2016, 10:34:55 am »
There ya go Subrosa  - Also notice the blue Render NURBs being active on the ribbon too :)