Update textures - parts names changed

Started by Kar, April 28, 2016, 11:31:15 PM

Previous topic - Next topic

0 Members and 1 Guest are viewing this topic.


Hello !

I have two SW assemblies.

I have made a very complete .bip from the old assembly (took me dozens of hours to do it, with animations, etc), but now I have received a newer assembly in which some parts have been changed. Of course the new parts have their name changed.

What I want to do is to keep all textures and animations from the old .bip in the .bip containing the new assembly. I could replace all new parts one by one and assign them textures and animations again, but that would definitely take me too much time (nearly as much as starting from the beginning).

I have thoughts of some solutions and have written the most realistic of them below. If you could give me advices on this solution and tell me if it would work or not, or if you have already found a solution while being in the same situation and could tell it to me, I would be very grateful.

  • Find new parts and replace their new name with their old name
  • Open new assembly in SW (with all new parts having their old names) and correct mates problems if necessary
  • Save SW assembly
  • Open KS6, import the new assembly or the new parts and select Update geometry

Thanks in advance !


Ok some news.

For the moment I have tried this solution :

  • Used the Keyshot plugin in SW and clicked on Export
  • Replaced old parts by new parts in SW, without changing their names
  • Used the Keyshot plugin in SW and clicked and clicked on Update

As a result, textures are kept but the problem is that animations and the "Separate textures" option have been lost.

Now I'll try with replacing names of new parts in SW and see if it keeps animations and options. Of course I'm still interested in your advices  ;)

Update : still the same problems as before. I also tried with "Render" instead of "Export", but it didn't even want to update.


Ok, none of the tested solutions work. I have also tried not using SW at all, only import assemblies / parts into KS directly, but does not work either.

I'm wondering if maybe this could be a bug from KS or from the plugin ? Because the update works well with textures and geometry, but it removes the animation while it shouldn't.

Is there a way to make it work ?

Thank you very much in advance and have a nice weekend !