Author Topic: Jittering with IES Spot lights  (Read 3078 times)

0 Members and 1 Guest are viewing this topic.

Offline sir.orange

Jittering with IES Spot lights
« on: September 01, 2016, 05:26:57 am »
Hi there,

I have a model of two rooms (interior lighting setting), the lights are all IES spot light in different angles and intensities.
I rendered an animation of 5sec (151 frames, FPS 30) that is a flight through the rooms. Setting was maximum time 5mins per frame.
The video that came out is jittering in the areas of the lights. What is the reason and how can i prevent the jitter? A collegue told me that the different frames need different amount of time to be rendered, so by setting the time to 5mins for each frame, different qualities of frames and lighting appear, is that right?
« Last Edit: September 01, 2016, 05:44:09 am by sir.orange »

Offline Will Gibbons

Re: Jittering with IES Spot lights
« Reply #1 on: September 01, 2016, 06:47:58 am »
Hi there,

I have a model of two rooms (interior lighting setting), the lights are all IES spot light in different angles and intensities.
I rendered an animation of 5sec (151 frames, FPS 30) that is a flight through the rooms. Setting was maximum time 5mins per frame.
The video that came out is jittering in the areas of the lights. What is the reason and how can i prevent the jitter? A collegue told me that the different frames need different amount of time to be rendered, so by setting the time to 5mins for each frame, different qualities of frames and lighting appear, is that right?

I'm not certain about the jitter/flicker effect, but your friend is correct about the time-based rendering. The best way to ensure quality consistency from frame-to-frame is to render at max. samples. Some frames will take longer to render, and others shorter, but the quality/noise/resolution should all be the same, frame-to-frame.

Offline sir.orange

Re: Jittering with IES Spot lights
« Reply #2 on: September 02, 2016, 12:13:47 am »
Ok, thanks for your quick response!
I just rendered the same animation with maximum samples of 65, the jitter of light is less it nearly diappeard, but instead there are much more "unrendered" reflexion on steel materials, their jittering is a lot more disturbing.
How do I prevent the jitter of surfaces - turn up the samples?

Offline Chad Holton

Re: Jittering with IES Spot lights
« Reply #3 on: September 02, 2016, 05:33:46 am »
Increasing the sample amount will help. Here's a quick tip that may be worth watching: https://youtu.be/yvvJGCOmzQY

Offline Will Gibbons

Re: Jittering with IES Spot lights
« Reply #4 on: September 02, 2016, 06:04:58 am »
Thanks for adding that video Chad. That should help. Additionally, making sure the color of your light is not 100% white helps. (Even 99% is better than 100%) Avoiding absolute white and black values always is a good idea in KeyShot. The color and specularity values may be able to be moved a few percent away from 100% white or black... see if that helps.

Offline Livingstone

Re: Jittering with IES Spot lights
« Reply #5 on: September 19, 2016, 08:50:34 pm »
Hi,
I see you use many texture . I found sometimes if you push too  much brightness value on the specular texture  map of a material, maybe to have more visible contrast,   you can have artifacts like those.