Author Topic: KS7 - Selection Outlines not visible _ Widget only working when zoomed WAY out  (Read 1987 times)

0 Members and 1 Guest are viewing this topic.

Offline riddickuliss

  • Newbie
  • *
  • Posts: 11
Windows 10 Enterprise
Keyshot 7.1.51
Modeled in Rhino (not using plugin)


I just started using Keyshot 7 last week. Yesterday I started having problems with the mapping tool / widget not showing up when trying to move a label, after searching the forum I tried zooming out until I could see it, but it only becomes fully visible when the model I am trying to manipulate is at about 900mm distance from the camera (both ortho and perspective and at 35mm and 50mm  focal length). This is frustrating, but not completely preveting me from working, HOWEVER the selection outlines are also not visible whether I select the part from the camera viewport or the model tree. I tried changing the preferences to use the CPU and restarting Keyshot and my computer and it made no difference. I also tried with with a simple cube from the add geometry menu to see if it might be something with my geometry.

This appears to be a problem with one file, I have tried saving as a new file and saving a package and reopening. Nothing seems to be helping. I deleted everything else from the bip except a cube and it is still happening (that is what is uploaded).
« Last Edit: December 22, 2017, 08:41:30 am by riddickuliss »

Offline theAVator

  • Sr. Member
  • ****
  • Posts: 306
  • Acting my shoe size since 1984
There may be something funky with the geometry or something.
I've run into this as well - not so much with the widget thing, but for sure where the part doesn't outline. I could click on another part in the model and the outline would work fine, click on the troubled part and nothing. For me it didn't really impact what I was doing, only thing I could think of was there must be something goofy with the geometry that was preventing it from doing what it was supposed to.

Something else to check may be the size of the part - do the numbers look abnormally large or are any of the parts 0 in size? I've run into issues where a single point way out in space gets left in by the engineer and the parts shows up like 5 million mm in size or something ridiculous. I've also seen parts that we 0 in size and keyshot doesn't like working with those. I had to scroll through a list of 1000 parts and scan for the 0,0,0 to pop up and delete those references.

I'm not sure either, but are you sure the mapping tool shows up on a label? Can you just grab the label and drag it around into position??

Offline mattjgerard

  • Hero Member
  • *****
  • Posts: 1757
Take a look at your environment size. I had this same problem, but my environment was scaled silly high, like 20,000 cm or something goofy like that. Probably happened because when you type in a number somewhere and hit enter, KS keeps that field active and if you start typing another something, it goes into that box.

Shrink your environment size down to something reasonable in relation to your model and your widgets should stay visible at closer distances.

Not sure if that will help the outlines or not. I do know that the keyboard shortcut for turning the outlines on and off is ALT+S.

Also for the labels, when you go to click on "Move Texture" in the Label tab, it defaults to "Click 'n Place" mode where you just click on the model and the label *should* snap to that point. I always always always get out of this mode by clicking on the "Position" button in the real time render window panel that pops up to turn off the  "Click 'n Place" mode. If you are in any mode other than UV for the mapping type, you will get your move widget gimbal thing back.

Offline riddickuliss

  • Newbie
  • *
  • Posts: 11
Thanks so much for the replies, I just tried a few things and realized it was only happening with one of the environments "3 panels Tilted 4k".
After reading your replies I noticed the environment (and ground) size was 1000000mm  Changing those sizes fixed both issues.
Thanks again!