Author Topic: Unable to Animate a parent object with hidden children via RMB menu  (Read 450 times)

0 Members and 1 Guest are viewing this topic.

Offline weezer19

I recently switched from Keyshot 6 Pro to Keyshot 7 Pro (it's the licenses we currently have).  Anyway, Animate is not an option on the RMB menu when selecting an object that has children that are "Hidden & Locked".  However, I can Animate that same object via the Animation Wizard...so I'm still able to accomplish my Animation, just not as handy.  Just curious if this is intended functionality to limit via the RMB menu or if I need to change a Setting?

Offline INNEO_MWo

  • Hero Member
  • *****
  • Posts: 1057
  • Total likes: 24
  • Senior Technical Consultant @ INNEO (Germany)
    • german KeyShot page from INNEO Solutions
Re: Unable to Animate a parent object with hidden children via RMB menu
« Reply #1 on: November 26, 2019, 08:04:10 am »
Hello weezer19.

I can't recreate this effect in KeyShot 8 or in the current version 9. So in KeyShot 7 you need to unlock or use the workaround via the animation wizard.


Marco

Offline weezer19

Re: Unable to Animate a parent object with hidden children via RMB menu
« Reply #2 on: November 27, 2019, 04:06:34 am »
I tried it again this morning having restarted my PC yesterday.  It does in fact continue.  To clarify, it's only if a lower-level child is "Hidden & Locked"...key-phrase being "Locked".  If the object is just Hidden, then the Animate option is in the RMB Menu.  Only when "Locked" does the Animate option not appear in the RMB Menu.