Author Topic: Glass + Plastic (Cloudy) interface  (Read 489 times)

0 Members and 1 Guest are viewing this topic.

Offline Andrew_G

  • Newbie
  • *
  • Posts: 23
Glass + Plastic (Cloudy) interface
« on: December 13, 2019, 02:27:58 am »
Hi,

I`m not sure is it the right place to ask, but after some tests I think that it is some sort of the bug and I should point that out.

I really love Plastic (Cloudy) material - you can generate a lot of usefull materials thanks to this. Especially now with speedup GPU rendering.

But this material is also great for creating different kind of liquids. Juices, milk, creams and so on. The problem is that it is almost impossible to clean it from noise if its behind glass. No matter how long or how many samples you use, it will always have some noise. Even denoiser cant handle it.

For some time I thought that maybe I`m doing something wrong. But I tested it in a lot of different conditions and from what I can see there is something strange with glass + some material interface.

Glass + glass or glass + liquid works perfect. But if you use translucent material or plastic (cloudy) it gets very noisy and a lot darker. And I believe that it is not how it should work in real life. Those materials are perfect for juices and all that kind of stuff and it would be really great if it start working as it should.

Just for test purposes I made some tests in Octane and Vray and those renderes doesnt have this issue...

Or maybe there is some option that needs to be turned on, but honestly I dont know where to find it... For working with glass+translucent material turning off Self Shadow helps a lot. Or just using old glass material with refraction turned on. But I have no idea what to do, to work with glass + plastic cloudy. Can you guys help me out with this?


PS. In Blender + Cycles, you can create speciall glass shader, that looks and behave perfect with on small difference. You can add speciall node that will tell renderer to pass every light sample if it concern everything behind glass. In octane there is option Fake Shadows. I tried to replicate it in KS but it did'nt work... But maybe this some way to find a work around.