Author Topic: GPU vs CPU issues  (Read 764 times)

0 Members and 1 Guest are viewing this topic.

Offline lmichas

GPU vs CPU issues
« on: January 17, 2020, 12:31:19 pm »
Hi,

I am seeing big differences between GPU rendering (which I prefer because it is almost 10x faster) and CPU. See the attachments for references. The basic problem is the the image is blown out on GPU but perfect on CPU. Especially in the areas where I have glass, or highly reflective materials. What is a solution to this? I have also included the Keyshot file.

Thanks,
Luke

Offline KeyShot

Re: GPU vs CPU issues
« Reply #1 on: January 17, 2020, 04:19:19 pm »
I took a look at your scene. The issue is that there is a color ramp procedural texture connected to the diffuse input on the translucent material. For the standard translucent material you should not be able to texture this component and the behavior is undefined. Instead it should be connected to the texture input on the material. If you wish to texture the diffuse component then the advanced translucent material should be used. We will fix this issue, so the diffuse component cannot be connected to a subtexture.

Offline lmichas

Re: GPU vs CPU issues
« Reply #2 on: January 21, 2020, 08:40:08 am »
Thanks for guidance on that. I have successfully moved the color ramp to the texture input and the issue is solved, however please see the 3 images attached. 1 rendered with GPU, 1 redered with CPU and 1 is a screen shot. My screen shot and CPU frame look great, but the GPU file that is output is totally blown out. What is causing this?

Offline PhilipTh

Re: GPU vs CPU issues
« Reply #3 on: January 22, 2020, 01:34:13 am »
Hello Imichas,

Did you perhaps change something since the first time you uploaded the scene?
I am unable to produce the above GPU issue using the scene you originally uploaded.

Please provide the newest revision of the scene, that you have.

Offline lmichas

Re: GPU vs CPU issues
« Reply #4 on: January 22, 2020, 08:49:16 am »
I don't think I changed anything other than the color ramp that was causing the original issues. Here is the file that I used to produce the screen shots and frame renderings.

Offline lmichas

Re: GPU vs CPU issues
« Reply #5 on: January 24, 2020, 07:38:58 am »
Any luck on figuring this out? I'm up against a deadline.

Offline PhilipTh

Re: GPU vs CPU issues
« Reply #6 on: January 27, 2020, 05:56:31 am »
I believe the issue occurs only when using background rendering.

If you use default, it should look correct.

I am unable to reproduce the issue using our next release (9.1), so the issue should be fixed there.