Author Topic: No shadow option on GPU?  (Read 1154 times)

0 Members and 1 Guest are viewing this topic.

Offline andy.engelkemier

No shadow option on GPU?
« on: May 19, 2020, 05:28:21 pm »
Ray Mask doesn't work with GPU.
If you have something like, an empty glass, it casts WAAAAAY too much shadow, even if you turn caustics on. You can make refraction 1.0 and still, shadow. Now, that's just wrong. A vacuum doesn't cast shadow folks.

So I usually use RayMask on thin glass, like a coffee pot, and just turn shadow off. If you have to choose a physically incorrect option, you choose the one that's closer to looking real right?

But, like I said. RayMask doesn't work on GPU. Any other way to make glass-like objects not cast a shadow? Or at least limit it to something more reasonable?
I'd really prefer just draw my "shadow" in photoshop, and put that on a plane below it....if it is even needed. I haven't got that far with this scene. I'll likely just end up having to render it in several pieces, and composite all of them together in photoshop. I just thought I'd ask to see if there were a better solution.