Author Topic: no way to restart render?  (Read 1150 times)

0 Members and 2 Guests are viewing this topic.

Offline andy.engelkemier

no way to restart render?
« on: July 09, 2020, 06:08:16 am »
I submitted one network render right after the other. It's Almost the same render. GPU with denoise. One has the product with the floor (that one rendered fine) the other has the product with no floor. That one said Processing at 8:1:37, then changed to finishing at 8:1:48 then failed at the same time. The other one, with the ground took 3 minutes and 8 seconds, which is about what I was expecting. It's just one part.

Trying to dig into the logs to see what may have happened isn't helping me much. After failing, the two machines that it thought GPU were enabled (several are, but it's only seeing two for some reason). I get the two workers saying "Manager: worker disconnected with id..." Then immediately after, "Manager: New worker connected with id..." It then received the other job and rendered it fine. However, I think it rendered just one one machine, which happened to be My machine, which was funny because I could have just rendered it without sending to the farm anyway.

I'm curious why there's no option to just tell it to try the render again? There are several cases where that might work just fine. And why doesn't the job try again a certain number of times automatically after the other jobs have tried?
Digging through worker gpu log, still not helpful. It says GPU Ok, cancelling job, render image failed. No reason for failing. But then the next job worked fine, which is the same file, only with a ground plane added.

I went back and submitted the exact same render again and it's fine. No idea why it failed, and I really wonder if it just tried again, would it have rendered without issue?

I was hoping I could do an old trick I learned from 3dsMax backburner back when I used that, where just changing priority caused it to go again. Or pause and restart (although that's grayed out in keyshot). No such luck. Is there actually a trick to get it to just try again?