"Ignore intersecting geometry" not working in GPU-mode

Started by MSRENDER, May 11, 2020, 03:04:55 PM

Previous topic - Next topic

0 Members and 1 Guest are viewing this topic.


Hi all,

I'm trying out the KS demo version in order to find out if we might purchase it or not.
When I try to render diamond jewellery the "ignore intersecting geometry" doesn't seem to work when rendering in GPU mode. In CPU mode it seems fine or atleast better, except when in the lighting menu the "jewellery" option is turned on. These are the settings that seem to affect the result directly. Anybody knows what is happening here  and what best settings are for diamonds? Will increasing raybounces have a positive effect on jewellery?

PS Also, is it faster to render this "complicated" light/refraction/reflection scene in GPU or CPU? Nvidia RTX 2080 ti here. I did some testing and my first impression is that cpu still produces better result in the same time.

I added a preview screenshot with GPU (55) vs CPU (56)


Hopefully someone at KeyShot is reading this, because I just bought a license for the program and I'm finding the same problem.  It's not consistent, however.  It seems like sometimes things render fine and other times they do not.