Author Topic: GPU rendering: object fade issue  (Read 5452 times)

0 Members and 1 Guest are viewing this topic.

Offline RRIS

  • Sr. Member
  • ****
  • Posts: 394
  • Total likes: 55
  • Renze Rispens - industrial designer
GPU rendering: object fade issue
« on: January 15, 2021, 04:13:31 am »
I'm not sure if this is a known issue, but I'm trying to render an animation with several objects fading in and out from 0 to 100% opacity. The problem is that in GPU mode, the invisible objects are partially still visible as some kind reflection or light.. it's really weird. In CPU mode there is no problem, but I'm not looking forward to rendering this animation over the course of a day when it should be done in a few hours tops.
I've tried changing the object shaders, but that doesn't do anything to solve it.

Offline RRIS

  • Sr. Member
  • ****
  • Posts: 394
  • Total likes: 55
  • Renze Rispens - industrial designer
Re: GPU rendering: object fade issue
« Reply #1 on: January 15, 2021, 04:25:11 am »
I think I have pinpointed the issue. It has to do with environment illumination. If you light your scene with object lights, everything's fine. If you have light coming from an environment, you get the ghosting.
I've attached a ksp with a fading cube to show the issue. Switch between environments (one is black) to show the problem. It's visible at the end of the animation timeline when the top cube is fully transparent.

Offline RRIS

  • Sr. Member
  • ****
  • Posts: 394
  • Total likes: 55
  • Renze Rispens - industrial designer
Re: GPU rendering: object fade issue
« Reply #2 on: January 16, 2021, 04:29:20 am »
Follow-up:

The issue with the fade is only visible when I use the Animation Wizard to create the fade.
If I use a Color Fade node in the material editor and link it to the Opacity of the shader, then everything works as expected and the object just disappears correctly.
Thought it might be useful to know for those who have the same issue.

Offline RRIS

  • Sr. Member
  • ****
  • Posts: 394
  • Total likes: 55
  • Renze Rispens - industrial designer
Re: GPU rendering: object fade issue
« Reply #3 on: January 29, 2021, 09:25:35 am »
At the off-chance that anybody finds this interesting or is also dealing with this issue.. I'm no longer seeing the issue if I enable GI + caustics in GPU mode. Only GI though and the fade doesn't work properly anymore.
« Last Edit: February 09, 2021, 09:04:38 am by RRIS »

Offline designgestalt

Re: GPU rendering: object fade issue
« Reply #4 on: February 04, 2021, 01:49:36 am »
hello RRIS,
I found this very helpful!
Thanks for posting this !

cheers
designgestalt

Offline ifeldown

Re: GPU rendering: object fade issue
« Reply #5 on: February 10, 2021, 09:19:49 pm »
I am having the same issue in KS9, not using GPU mode but when trying to use the animation wizard (I do have GI and caustics on).  Essentially the faded out material stays (I am rendering a diamond) and causes the visble one to be distorted (totally black instead of clear).

Offline Mrcl

Re: GPU rendering: object fade issue
« Reply #6 on: March 03, 2021, 08:31:38 am »
Thanks RRIS
I had the same issue.
That was very helpful to me.




Offline melzel13

Re: GPU rendering: object fade issue
« Reply #7 on: April 27, 2021, 07:12:31 am »
Thank you for posting. I am having the same issue and I am working on a mac. Is there any way to resolve this?

Offline Kuba Grabarczyk

Re: GPU rendering: object fade issue
« Reply #8 on: October 15, 2021, 09:58:56 am »
I am having the same issue. Using Keyshot 10.2 Pro when using fade animation and the GPU mode some parts are flickering showing up and hiding themselves even though it should be faded out. I do not use animation wizzard, just righ clicking on the object name and choosing animation>fade, My GPU is RTX 2070,

Interesting: it works perfectly fine with CPU
Interesting 2: it WORKED perfectly fine when I set up all the fading animations, the issue appears when I close Keyshot and run it again (it means I lost the only chance to render it when I closed the keyshot)

Can anyone from Keyshot support team try to help here? It seems to be major issue and so far nobody cared about it...

Offline wayneheim

Re: GPU rendering: object fade issue
« Reply #9 on: November 08, 2021, 11:33:28 am »
I'm having the same terrible issue with 10.2. Fade from 0-100 and at about 98% it jumps to 100% and you get a flicker.  Also having issue with objects that are hidden (fade from 0%-0%) are showing up when something overlaps them that has transparency to them as well. Now things seem to improve when I go into gpu mode but rendering in gpu is too slow.

Note, anyone doing animation rendering, if you render the scene in background, KS will only send the resources to your card on the first frame vs every frame. Problem is that when rendering using gpu, my KS only uses at max 35% of any of my 3 gpu's but in live view it uses 100% of all. So it is faster for me to render animation via cpu (dual xeon).