KS10.1 Can't get new 'Settle' button to work at all

Started by Aeonjoey, February 08, 2021, 04:47:34 PM

Previous topic - Next topic

0 Members and 1 Guest are viewing this topic.


I've tried with about a dozen files, no matter what I select, no matter how busy or not the scene is, if I pick any object and click the 'settle' button, it just brings up a progress box that says "Setup" and stops at either 5% or 48% and hangs. The app otherwise is completely unusable, everything becomes grayed out and clicking "Cancel" says "Setup (Canceling)" for several seconds or sometimes forever, and either it goes away or the app hangs indefinitely.

I've tried both with an upgraded installation and a fresh installation on this machine.
(MacBook Pro 16" w/ 32gb RAM)

I know I can submit a ticket, I just want to know if anyone has gotten this to work and I should submit a ticket


Two things first. Try this feature in a more clear scene that is reduced to some parts. In this case I would use a scene with the bowl and the bolts. And make sure that the parts don't intersect. If the mesh of the bolts isn't  'watertight' closed, check the 'as parts' option in the move tool widget.

This prepared scene can be imported in the complex scene.

Hope that a quick tip guide will be available on YouTube.

Good luck!



Thanks Marco,
I have tried it and no go, I'll just have to blame the complexity of the models - pulling them apart to ensure there is no intersection didn't matter, same issue. I was able to get it to work with a fresh scene and primitive cubes however, so it's not an app bug per-se, but some difficulty from our models maybe.
First thing I tried was exporting the model set to a new file, then exporting the selected 'bolts' as individual OBJs each, and the bucket, and then re-importing them into a new scene, one at a time, with just the bucket and one bolt, it did the same thing - stuck at "setup 48%" I haven't gotten any of our models from other files with other products to work either using the same process of isolation and elimination.
Even importing fresh CAD from Rhino of individual objects into KS and a cube - does the same thing.
Shame - was really looking forward to this.

Incidentally - I can't get collision to work with any of our models either, checking the collision box with a single model selected just does spinning beach ball forever and I have to force-quit KS.

Again, I can get it to work with primitives like cubes. must be our files.

[email protected]

I will also be watching this for some improvements.  My experience with this so far was bad, then worse depending on the model.   Issues I have seen are that some parts clip the object that they are supposed to land on or intersect with other objects in the scene, the parts never stop moving or they do stop, hovering midair. 

Another thing I have noticed on the update is an attempt to snap an object or assembly to a lower object with the collision checkbox activated,  will result in a never-ending progress bar (sometimes you can cancel it, sometimes not and the only way out is the three-finger salute). 


It does have a direct impact from the complexity of the geometry. In general, KS uses a bounding cube to define the edges, when you hit settle, it shrink wraps that bounding box to the exact geometry, so it can take awhile. I would believe that at some point it could just lock up and give you the middle finger, Cinema 4D can do this sometimes on more complex dynamics scenes as well, so its not exclusive to KS. This is introduced as a super basic simple way to do settling and filling containers. More complex geo and sims will require other software for now. I think you have just discovered that line for your project.