Author Topic: Viewport crashing, objects not displaying  (Read 1893 times)

0 Members and 1 Guest are viewing this topic.

Viewport crashing, objects not displaying
« on: June 24, 2021, 05:16:23 am »
Hi everyone,

in my file, random objects start disappearing in the viewport. Some parts of the group may be still visible, and when changing their visibility, they might appear randomly, but hiding the other parts instead. Switching to Performance Mode doesn't help, after a while viewport just completely crashes and KS is unusable.

I just don't know where to begin troubleshooting this. It appears as if some kind of memory is at its max, but which one? I've worked with this file before in KS9 and it performed well, on the same machine. The file is about 1,4GB and has a several model sets. It also has quite complex model structure in the scene tree. Is there a limitation on grouping levels (which I need for an animation), or is this a performance issue at all? Again, it worked well in KS9.

Is there a general checklist on what to do when experiencing performance issues or an explanation on how they are linked to certain hardware shortcomings?
 
As this is a client project, I cannot share the scene unfortunately.

In the screenshot attached, the whole vehicle is supposed to be visible.

Hardware:
Threadripper 1950X 16 Core
32GB RAM
GTX 1080
Keyshot 10.2 Pro

Thank you everyone in advance.

-Rob

Offline Erik Williams

Re: Viewport crashing, objects not displaying
« Reply #1 on: June 25, 2021, 05:10:43 am »
Hello Rob,

I noticed that GPU mode is not available on your computer. The GTX 1080 is not a supported GPU, but you can try to update your drivers to the latest version to see if that solves the issue in your Real-Time View.
We recommend driver version 458 and up.
You can use Nvidias tool to search for the most recent driver at https://www.nvidia.com/Download/Find.aspx?lang=en-us

Let us know if this helps.

Best Regards,

Erik

Re: Viewport crashing, objects not displaying
« Reply #2 on: June 28, 2021, 03:15:32 am »
Hi Erik,

thank you for your reply. The 1080 drivers were actually pretty much up to date (updated it yet again though after your recommendation), but in the screenshot, Performance Mode was activated, and from there, GPU mode is greyed out? I can launch GPU mode and so far it works consistently, but... I cannot select anything and use the right click menu in GPU mode. Is that by design or also a bug / driver issue?

Is there a general document where performance issues are explained? Again, I feel like I'm stuck in a void not knowing which parameters to change to navigate out of this situation.
 

Offline Erik Williams

Re: Viewport crashing, objects not displaying
« Reply #3 on: June 28, 2021, 04:17:02 am »
Ah I see.
Yes GPU mode cannot be used while in Performance Mode and vise versa. GPU mode uses a majority of the same processes as Performance mode, and there would be nothing gained by either process to activate the other.
This, combined with the GTX 1080 is the reason why you are experiencing this issue.
This was the case in KeyShot 9 as well. You may have experienced a small UI bug when enabling both of these features that has since been solved.

We apologize for the misunderstanding. I hope this clears things up.