Author Topic: Can't use Scale slider or number entry - moves model part elsewhere in scene  (Read 539 times)

0 Members and 2 Guests are viewing this topic.

Offline Aeonjoey

Hey there, I essentially need to scale about 40 objects in my scene in place. Each of them needs to be taken down to 75% of their original size but exactly in the same places where they are. I don't care how long it takes to do it, I need to do it, so I'm trying to scale each of them one at a time to 75% or 0.75 Scale. BUT they all MOVE by themselves to a different position in the scene every time I try to use any method of scale other than freehand.

If I use the Move Tool > Scale widget and freehand scale with the yellow box it works (!!!), but I can't pinpoint .75 with it at all.

If I try to type in a value into the 'Scale' slider in the scene tree OR the 3 scale sliders in the Move tool - the object moves to different location.

All of the objects that I try this with scale relative to the center of the scene, which makes no sense because they were imported and then duplicated each one at a time and moved. I've tried moving the objects in the scene tree out of groupings to be at the root level and the same thing happens.

If I click 'Copy Position', then scale and it moves, and then click 'Paste Position' it returns to it's original location but also resets the scale back to 1.

I've tried Global/Local and every switch and setting I can click. Always the same results.

Is there no 'Scale in place' or better yet 'Scale each' sort of functionality? maybe a script? is this a bug or by design?
« Last Edit: October 20, 2021, 12:57:12 pm by Aeonjoey »

Offline TGS808

If I'm correctly understanding what you want to do, try this...

Use the move tool. When you click the yellow box to start freehand scaling, a new box that you can type in will appear in the move tool dialog box. (see image) There you can pinpoint the .75 and the part will scale but not move. The box also appears for rotation and translation. Give it a try.