Wrong version of KS opening files

Started by davetwo, March 07, 2022, 06:59:37 AM

Previous topic - Next topic

0 Members and 2 Guests are viewing this topic.


Hi all. Whenever I double-click on a KS file it tries to open it in my old version of KS7 and not my new subscription version of KS 11. It's driving me crazy!
Im on Windows 10 - and can useally select a  the right version with the 'open this file with..' dilague. But that cant find the Keyshot 11 application.
Any idea what is happening here?


Justin A

Typically when double clicking a .bip or a KSP the last installed version of KeyShot will open.
If you recently re-installed KeyShot 7 then This will be the version it will open.  I would suggest either removing the older version or you can reinstall KeyShot 11 so that KeyShot 11 is the latest  installation on your machine.


That's not the problem.
KS7 has been installed for years. KS11 is a new install as of a couple of weeks ago.

I suspect that this has to do with the installation location. I (wrongly) thought the 'install for the current user' was the most sensible option over 'insall for everyone using the computer'. But this seems to have effectively hidden the KS location. (Why would anyone want this?)

Erik Williams

You say that the KeyShot 11 exe file is hidden, is that correct?
There could be a few things causing this.

The executable file is located by default in:
C:\Users\<USER>\AppData\Roaming\Microsoft\Windows\Start Menu\Programs\KeyShot 11
The Resource folders by default should be in:
C:\Users\<USER>\Documents\KeyShot 11

If they are not there and you installed everything to a Network Drive, or are linked to something like OneDrive, this could be causing the issue. Network drives have a nasty habit of migrating everything over to their dedicated folder, which could cause the previous file to not be able to actually find KeyShot 11 and open KeyShot 7 instead. If this is the case and you want to continue using the network drive:
We highly recommend first installing KeyShot locally.
Then, through the Preferences option, add your network drive file paths to the correct folders.
This will give you access to all items stored on your network drive, while making sure your primary file paths to the plugins folder and XML files are segregated and not affected by any changes made by other users.

To modify your Resource File Path:

    First, it is recommended that you create a backup of your Resource Folder to save any textures, models and renders
    Uninstall your current installation of KeyShot
    Download a Fresh Installation using the Full Installer
        The latest build is available at https://www.keyshot.com/resources/downloads
        Previous versions of KeyShot can be found at https://www.keyshot.com/resources/downloads/previous-versions/
    Download KeyShot to a local drive
    Follow the instructions provided during installation and launch KeyShot as normal
    Once launched, open your Preferences and select 'Folders'
    Here, you will see what file paths are used to access your files. Click the Folder icon next to the desired folder and add your Network File Path.

You should now have access to everything on the Network Drive while maintaining the integrity of your personal settings and information.

Another possibility is your user permissions. Even though you installed as 'just for me', as cliche as it sounds try making sure you have Full Permissions to the locations you installed KeyShot and the Resource folder. In the folders be sure to check if 'Hidden Items' is checked off.
If so, remove the checkbox to see if you can find the files.


It is not installed on an extenal drive, and all the premissions are OK too.
I guess I'll just have to re-install using the 'for everyone' option  :(


This is a windows registry thing, so something must have happened. this happens to me all the time when installing beta versions of software (not just Keyshot) and this is one of my main gripes about windows. The "Open With" windows dialoge should in theory take care of this, but for some reason windows developers feel the need to absolutely bury their exe files in hidden obscure folder structures so that trying to get that "Open With" to find the correct app version to open files with is nearly impossible. This again is one thing OSX has right, they don't spray files all over the place and make them hard to find. I'm not a developer, so I have zero idea why things are done in a certain way, but you'd think that all the program files that pertain to running a program would reside in the "programFiles" folder in the windows structure. But nope, its in the hidden AppData, Local, or even more unexplainable Roaming folder. just doesn't make sense to me. I have taken to making a folder on my desktop that holds shortcuts to all of my pertinent actual application exe files so that I can find them quickly.

So, in your case, you need to head to C:\Users\USERNAMEHERE\AppData\Local\KeyShot11\bin\keyshot11.exe and make a shortcut to that guy on your desktop. KS installer does give you the option to create this link when installing, I believe, but here it is just in case.


Thanks for your excellent reply.
Unbelievably, even when I go to 'Open with' command and navigate to the (well hidden) Keyshot.exe in the Keyshot 11 folder it still manages to open KS7.
I'm going to give up and go for the reinstall

Erik Williams

I believe mattjgerard is correct. Most likely it is a Registry issue. If you are still having this problem, press the Windows key and enter 'reged' to open the Registry Editor.
After opening the Registry Editor, browse to either:

    Computer\HKEY_CURRENT_USER\SOFTWARE\Luxion\KeyShot 11
    Computer\HKEY_LOCAL_MACHINE\SOFTWARE\Luxion\KeyShot 11

Confirm that the Resources lead to the same file-path as ResourceFolder.
If everything is still installed as 'just for me', in BinFolder you should see something similar to - C:\Users\<User>\AppData\Local\KeyShot11\bin.
BinName should read - C:\Users\<User>\AppData\Local\KeyShot11\bin\keyshot.exe

The odds are the BinName may still be pointing to C:\Users\<User>\AppData\Local\KeyShot7\bin\keyshot.exe or some variation.
In this case, browse to C:\Users\<User>\AppData\Local\KeyShot11\bin\ and confirm that the keyshot.exe file is there.
You can edit any incorrect entries by right-clicking on the incorrect Name and selecting 'modify'.

Let us know what happens.