Author Topic: Ghosting in Fade Animation  (Read 831 times)

0 Members and 1 Guest are viewing this topic.

Offline iDon23

Ghosting in Fade Animation
« on: April 25, 2022, 08:40:35 am »
Hello fellows.

I am working on an animation and get this ghost effect where hidden objects overlap ground shadows. It is unclear to me what would cause this issue.

At first I expected it to be the Photographic image style as it would make things darker in post and therefore highlight those hidden objects somehow, but this shouldn't be the case anyway. And I also get the same effect in Basic image mode.

Render in KS 10 CPU mode.
Global Illumination ON
Ground Illumination ON
Product Mode
Ground Shadows ON

Offline theAVator

Re: Ghosting in Fade Animation
« Reply #1 on: April 26, 2022, 06:04:30 am »
Are you rendering transparent frames(like png with transparency) or the whole scene including background color/backplate (jpg)?

Offline iDon23

Re: Ghosting in Fade Animation
« Reply #2 on: April 26, 2022, 07:58:49 am »
Yes, Indeed working with transparent background in .png format

Whithout transparency the effect seems to be gone, at least for a short sample I tested.
I would want to add effects underneath the animation though, so I thought it easier to render with transparency instead of post editing the animation for it to allow effect layers underneath.

I guess there is no other way to get rid of these artefacts and keep transparency intact?
« Last Edit: April 26, 2022, 09:11:09 am by iDon23 »

Offline theAVator

Re: Ghosting in Fade Animation
« Reply #3 on: April 26, 2022, 01:48:11 pm »
That's kinda what I was thinking was happening.
If you're ok with some post processing, you can change your enviro/background to a green key and then key it out in Premiere or whatever video software you're working with. This has been an on/off issue going back to like version 5 or 6. So my process for dealing with it has been to either eliminate the need for shadows and such, or to render with a color key background and remove it in post-prod. Not sure what your process is/has been, but typically I'm only rendering the frame output and then import it as a sequence in Premiere and do all my processing from there.

Offline Will Gibbons

Re: Ghosting in Fade Animation
« Reply #4 on: April 27, 2022, 07:35:43 am »
Those faded/hidden objects... are they touching the ground plane? What if you raise them .01mm? Does it still cause the issue? I'd do a test frame and see.

Offline iDon23

Re: Ghosting in Fade Animation
« Reply #5 on: May 03, 2022, 11:39:44 pm »
The objects do not touch the ground. They are in contact with the other objects in the scene though.
For now I can work with theAVator's suggestion, using .jpg's instead of .png and go for the post processing elsewhere.

Thanks guys

Offline shane.ploenges

Re: Ghosting in Fade Animation
« Reply #6 on: May 16, 2022, 06:23:36 pm »
I just posted after this with the exact same issue and did not see this post before doing so.  It is exactly the same thing happening if i enable transparent background and output my file s- i get a white/ghosted effect on any objects i have applied the fade animation to.

Can someone tell me if this is still an issue in KS11?  its kind of a bad thing to have to do a keyed background and edit in post, we should be able to use the transparent BG output and not get artifacts in our renders with fade animations.

Offline theAVator

Re: Ghosting in Fade Animation
« Reply #7 on: May 17, 2022, 11:18:48 am »
idon23 - can you try putting a ground plane or a sweep or some sort of object behind the items being faded and see if that produces a different result? Might be helpful to see if it presents the same issue that shane.ploenges is seeing, but because yours is over transparent background and his is over other objects we can't really conclude that they are the same issue yet.


Offline iDon23

Re: Ghosting in Fade Animation
« Reply #8 on: May 23, 2022, 07:23:05 am »
I checked with a ground plane and transparency applied. I do NOT get the ghost artefacts. So for me it provides the ideal solution, as the groundplane does not appear in the .png