KeyVR 11.1 Now Available

Started by Jan Simon, August 10, 2022, 05:45:13 AM

Previous topic - Next topic

0 Members and 1 Guest are viewing this topic.

Jan Simon

We have just released KeyVR 11.1 featuring OpenXR support and a brand-new tool: Sketching.

Here's a full changelog:

  • Adopted OpenXR standard, enabling KeyVR to support any OpenXR-compatible headset
  • Added new sketch tool
  • Added a slider in the preferences to better control the amount of Variable Rate Shading applied (only available with Turing or newer NVidia GPUs)
  • Removed backface culling checkbox in the preferences
  • Reworked graphics quality presets (low, medium, high, ultra and custom) to have a larger effect on performance
  • Replaced individual controller models with avatar hands in VR
  • Tweaked main window and side bar UI


OpenXR enables KeyVR to support any current and future headset that is compliant with the industry standard. And you can now even run KeyVR on a Meta Quest 2 using Air Link, fully wirelessly, with minimal and extremely setup in the headset.

The new sketch tool allows you to quickly and effortlessly sketch out new design ideas, jot down quick notes or make annotations, all without ever taking the headset off. The tool turns your hands into pressure-sensitive paintbrushes which you can use to sketch free hand or directly onto surfaces. The tool supports KeyVR Connect for shared sketches, as well as saving and loading of sketches for later review.

You can get access to KeyVR right now by launching your currently installed KeyVR and clicking on the "Update" button in the Welcome Window - or grab the download off of our website right now.

As always, we're more than excited to hear from all of you and get your feedback! Please get in touch right here in our forums or via [email protected].


Mario Stockinger

Maybe you should mention that you killed microsoft mixed VR headsets with this Update....

Even with OpenXR Runtime installed it doesn't work - great job. Our HP Verb G2 Rev2 is now for the trash.


I've tried to use KeyVR 11.1 with a Windows Mixed Reality HMD (an old Samsung Odyssey+) with success. Just set the SteamVR settings as suggested in the manuel and it works.


Jan Simon

Yes, we have not affected our support for Windows Mixed Reality headsets in this update and are using the HP Reverb G2 ourselves in the office, amongst other headsets. The manual has indeed been updated with steps you can follow to make sure everything is set up correctly, as Marco said:

If you used to run your G2 through the Windows Mixed Reality Portal app and then into SteamVR with the Windows Mixed Reality plugin, this exact workflow should still work. If KeyVR doesn't detect the headset, you simply need to click on the menu button in the top-left of the SteamVR window, then select Settings → Show Advanced Settings → Developer and click on the "Set SteamVR as OpenXR runtime" button. Here is the first page in the manual that goes over this:

Mario Stockinger

Following the Guide i was able to get KeyVr working again but i can't get the controllers to get to work.

In the Steam VR for Mixed VR app when i check  the Controller Test , the Left Controller works , i see input, for the right controller i can't see inputs.
Steam VR is registered as default OpenXR app.

In the Windows Mixed VR window there is the banner that says windows Mixed Vr is not the default app with a repair button but that seems to be ok i guess.

I see the controller in SteamVR,  i can use them both to move around in the Steam VR default mountain Environment.
In windows i checked BT and they are connected. I used fresh batteries.
I see the controllers in the "loading" enviroment with the circles in raster and the floating keyshot window.

But as soon as KeyVR is fully loaded with a model the controllers disappear. In KeyVr The Left and right Controller Drop Down are greyed out....

I have no clue what could case this problem.....

Jan Simon

Weird, if you are seeing your controllers in SteamVR they should also be registered in KeyVR. Your setup is correct.

Just to confirm: You are using the Windows Mixed Reality controllers that come with the HP Reverb G2, right? I will re-test your setup today to see if I can reproduce the controller issue.

Mario Stockinger

No i use the controllers from our old acer mixed VR for my test system. I know they are a little bit different. The Reverb Controllers are only for the Exhibition and our showcase room.

Jan Simon

Is it these controllers? These look like pretty normal Windows Mixed Reality controllers and should still work with OpenXR. I will see if I can find these controllers to test them specifically.


I use exact these type of controllers.

Mario Stockinger

Yes these are the controllers i use for testing. I ordered a pair of Reverb G2 controllers too so  i have my own pair because i am not allowed to  use the ones from the show room.

Just to give you the specs of my VR Set : Ryzen 9-9500X  , 128GB Ram Quadro A6000, W11Professional

Mario Stockinger

I did more testing - i reinstalled my Test PC , This time with W10 Prof. but it's the same result.

I begin to think that maybe SteamVR is the issue - i have  Version 1.23.7 installed.

Jan Simon

I am also on 1.23.7 here. Please let us know if the Reverb G2 controllers also don't get recognized!

Mario Stockinger

Yea DPD did not deliver today so i will test them on monday asap.

Mario Stockinger

With the new Controllers i got it working once with the W10 Installation and saw the 2 Keyshot hands for controls.  When i swapped the M2 Disks back to the W11 installation i was not able to get it to work again.

When i start SteamVR sometimes i see 2 white hands, then sometimes i see 2 holographic Controllers, sometimes one Controller looks like a white hand one has a holographic look in the Steam VR mountain scene.
But i had this behavior with the 2 original Mixed reality controllers too so nothing new to report.

Mario Stockinger

I replaced the Disk again with the W10 installation and tried to repeat my steps but i didn't get it working.

Doesn't matter if i only start keyvr or if i start steamvr first, as soon as KeyVR has completed loading the controls dissappear.
This time in all my tests in the steam VR mountain environment the 2 Reverb Controllers appeared as white hands. No FLickering....

I really don't know what else i could test. This is far away from plug and play.

We have an exhibition in the first week of October where we wanted to use keyvr but with this version it is impossible. Maybe we use the older Version which is realy fire and forget and just works..... But only with half fps....