Author Topic: Rendering is jagged and nurb rendering is not working.  (Read 1266 times)

0 Members and 2 Guests are viewing this topic.

Offline NineAmulets

Rendering is jagged and nurb rendering is not working.
« on: September 18, 2022, 06:28:44 pm »
I never used to have this problem before. Even though the image looks great, still has a lot of jagged lines and no matter what setting I use and even using denoise it doesn't go away. The render nurbs button is gray and it doesn't work. Any clues?

Thanks

Online TGS808

Re: Rendering is jagged and nurb rendering is not working.
« Reply #1 on: September 18, 2022, 09:56:23 pm »
Your model seems fine. If you’re referring to the dark, jagged lines reflected on the inside of the ring, it’s not a geometry issue. It’s the HDRI environment. Use a higher resolution HDR image for the scene and you won’t get jagged lines like that in your reflections. Either that or you could try scaling the current environment down in size. You may have stretched the image beyond its usable limits for reflections.

Offline NineAmulets

Re: Rendering is jagged and nurb rendering is not working.
« Reply #2 on: September 19, 2022, 08:35:49 am »
Thanks. Yes, it appears to be environment images. I did notice that they look low-res even as you look at the thumb pics. They all look low-res and kind of blurred. I downloaded some from the cloud, and they look the same. How do I get the hi-res images? Is that some setting I have to change in KS

Thanks

Online TGS808

Re: Rendering is jagged and nurb rendering is not working.
« Reply #3 on: September 19, 2022, 10:45:45 am »
That one you're using is only 2000x1000. So, you can either make a custom one in the HDRI editor or if you want to continue with a photo based HDR image, you can get very high-res files, for free here: https://polyhaven.com/hdris

Offline NineAmulets

Re: Rendering is jagged and nurb rendering is not working.
« Reply #4 on: September 19, 2022, 12:34:31 pm »
I've downloaded a picture from the cloud that says 6000 x 3000, and the same thing happened. All the pictures that come with KS are high res, and I didn't have this problem before. It must be something else...OK, this is a new render using an environment downloaded from the site you recommended, 16K, and the result is the same and even more jagged. 

Online TGS808

Re: Rendering is jagged and nurb rendering is not working.
« Reply #5 on: September 19, 2022, 12:57:56 pm »
Strange. I'm getting smooth reflections using that initial HDR. This is a 20mm ring in an environment that is 297mm. Can you upload your KSP here? Maybe something else is going on.


Offline NineAmulets

Re: Rendering is jagged and nurb rendering is not working.
« Reply #6 on: September 19, 2022, 04:32:01 pm »
Yes. This render is what I'm used to with KS right out of the box. Here's the KSP...Thanks

Online TGS808

Re: Rendering is jagged and nurb rendering is not working.
« Reply #7 on: September 19, 2022, 04:43:55 pm »
The KSP you attached was empty. There's no model in it and the environment is the startup HDR.

Offline NineAmulets

Re: Rendering is jagged and nurb rendering is not working.
« Reply #8 on: September 19, 2022, 07:37:59 pm »
Try this one.

Online TGS808

Re: Rendering is jagged and nurb rendering is not working.
« Reply #9 on: September 19, 2022, 10:36:55 pm »
On close inspection, I realize I was wrong. It is your model that is the problem. It's not smooth. You can see in the image, the HDR is clear. It's your model that has the lines in it. You need to smooth it out in your modeling program. I see that's Z Brush but I don't know anything about Z Brush and can't make a recommendation. Maybe someone else here can. Also, you are working in meters. For something as small as a ring you may want to go with millimeters for your scene units.

Offline NineAmulets

Re: Rendering is jagged and nurb rendering is not working.
« Reply #10 on: September 19, 2022, 11:55:15 pm »
Thank you for your support. I will try some changes based on your recommendations. The model has millions of polygons, I don't think that's what it is but the scene being in meters might be the problem. Thanks

Offline RRIS

  • Sr. Member
  • ****
  • Posts: 404
  • Total likes: 61
  • Renze Rispens - industrial designer
Re: Rendering is jagged and nurb rendering is not working.
« Reply #11 on: September 20, 2022, 01:02:17 am »
Sometimes I get those unsmoothed models in Keyshot, and I know I have smoothed them in my 3D software. In such cases you can try to use the Keyshot geometry edit to re-calculate the normals. That solved it for me the last time this happened.

Offline mattjgerard

Re: Rendering is jagged and nurb rendering is not working.
« Reply #12 on: September 20, 2022, 05:24:15 am »
When Importing things I have made in Cinema 4D i have had to recalculate the normals, and that worked. Wish there was a way to do that on import, would save me a ton of time.

Online TGS808

Re: Rendering is jagged and nurb rendering is not working.
« Reply #13 on: September 20, 2022, 07:37:05 am »
Excellent tip from RRIS here. I've never encountered a problem like this in my own work, so editing the normals isn't something I would have thought of. Out of curiosity, I tried it and it worked. And, it was easy. I just went into the EDIT NORMALS tool and clicked the CALCULATE VERTEX NORMALS button with everything at their default settings. It completely fixed the issue. Nice to see this can be done inside of KS.


Offline RRIS

  • Sr. Member
  • ****
  • Posts: 404
  • Total likes: 61
  • Renze Rispens - industrial designer
Re: Rendering is jagged and nurb rendering is not working.
« Reply #14 on: September 20, 2022, 10:27:04 am »
Glad it worked :) Also, millions of polygons is probably overkill for a model like this. Your model will probably look absolutely fine with 1/10th of that.

edit: to elaborate a bit further, the last time this happened to me was with an imported .stl file, they sometimes have missing smoothing info (if they have it at all), and you can fix that by recalculating the normals in keyshot.
« Last Edit: September 20, 2022, 10:36:37 am by RRIS »