Problem with Plugin not recognising Keyshot Installation

Started by NormanHadley, January 26, 2012, 11:46:45 PM

Previous topic - Next topic

0 Members and 1 Guest are viewing this topic.


Hi. I had been having a lot of problems with KS3 (including the fact that the Pro/E plugin never worked) so did a clean install of KS3.0.99 (Win7-64) then installed plugin 1.1 (WF5->KS3). During the plugin installation, an error message came up warning that it couldn't find an installation of KS3. A similar message comes up when I try to run the plugin from Pro/E so it still doesn't work.

I suspect this is because I have installed KS3 to a nonstandard folder (d:\Keyshot 3 for disc space reasons). Can I tell the plugin somehow that there is a real, live install of KS3....just not in the usual place?


You would have to change the path in the protk,dat file.


Sorry Thomas, I'm still struggling. This is where my KS3 installation lives.


Within that folder is the path where the plugin is installed

D:\KeyShot3\KeyShot3\Pro Engineer 5.0\

And in there, the protk.dat contains:-

NAME KeyShot3
EXEC_FILE D:\KeyShot3\KeyShot3\Pro Engineer 5.0\keyshot3_proe5_plugin.dll
TEXT_DIR D:\KeyShot3\KeyShot3\Pro Engineer 5.0

I can register it OK, run it OK ("Application Keyshot3 started successfully") and the drop down appears OK ("Render", "Keyshot Settings") but as soon as I try to transfer to KS, I get "No Keyshot installation detected"


Hi Keyshooters

This problem was never resolved so I'm bringing it back to your attention. I left it alone because I was content to revert to KS2.3 but not now I've installed KS3.1 and want to get to grips with it.

Here is the relevant text from Pro/E's applications register...

Application 2: KeyShot2
Exec path: D:\Keyshot2\Plugins\Pro Engineer 5.0\keyshot_proe5_plugin.dll
Text path: D:\Keyshot2\Plugins\Pro Engineer 5.0
Version 29 - 2010280
Application is running.

Application 3: KeyShot3
Exec path: D:\KeyShot3\Plugins\Pro Engineer 5.0\keyshot3_proe5_plugin.dll
Text path: D:\KeyShot3\Plugins\Pro Engineer 5.0
Version 29 - 2010280
Application is running.

Here is the output from a cmd prompt to show that both those paths are valid.

Directory of D:\Keyshot2\Plugins\Pro Engineer 5.0

13/12/2011  14:32        20,254,208 keyshot_proe5_plugin.dll
               1 File(s)     20,254,208 bytes
               0 Dir(s)  223,133,143,040 bytes free

C:\Users\Norman>dir "D:\KeyShot3\Plugins\Pro Engineer 5.0\keyshot3_proe5_plugin.dll"
Volume in drive D is Data
Volume Serial Number is D857-0CD0

Directory of D:\KeyShot3\Plugins\Pro Engineer 5.0

18/01/2012  11:03        15,001,088 keyshot3_proe5_plugin.dll
               1 File(s)     15,001,088 bytes
               0 Dir(s)  223,133,143,040 bytes free

The KS2 plugin works fine but the KS3 one gives the "No Keyshot Installation Detected" error.



Hi marinpo

My problem has just been resolved with some help from my reseller, Inneo. The solution, somewhat counter-intuitively, was to do a complete reinstall of Keyshot after the installation of the plugin. They're now talking to each other just fine. Hope that works out for you too.



I sure appreciate your feedback. I'm going to try and do a KeyShot reinstall to see if that works for me as well. By "complete reinstall" do you mean uninstalling first and then reinstalling?



Hi Br3ttman

I didn't need to uninstall the existing Keyshot but did have to do a full install over the top of the plugin. That seemed really odd to me - the problem was the plug-in wasn't finding the Keyshot installation so how come it worked when I installed the plugin for a Keyshot installation that wasn't even there yet?

Very odd, but it worked. Hope something similar works for you.



Well I tried the reinstall method to see if that might work and hosed up all my libraries and had to reimport them. Unfortunately, after all the work, I still couldn't get the ProE plug-in to work.  I appreciate your input though.

Is there even an advantage to having the ProE plug-in functioning?  Can anyone tell me what I might be missing?


I am having this same problem. I am using Creo 2.0, and Keyshot 3.2 on a floating license.
I installed the Creo 1.0 plugin.

Previously, I had Keyshot 2.2, local license, and I was able to get the Wildfire 5 plugin to work in Creo 2.0.

So I'm not sure if I should be using the Creo Plugin, or the Wildfire 5.0 plugin. Either way, I am wondering if it will even work with the floating license Keyshot 3.2.

Any help is appreciated.


It will work with the floating license. There is an updated plugin on our website. Download, install, and follow instructions.