Label on glass (two-sided) gives the glass an unwanted tint - help a KS-newbie?

Started by honeymunchkin, March 12, 2012, 10:16:43 AM

Previous topic - Next topic

0 Members and 1 Guest are viewing this topic.


I'm very new to KeyShot (I'm on KS3) and I'm trying to render images of nail polish bottles.

Without a label on the glass bottle the content shows correctly with colors and all that, but as soon as I put a label on (have tried .png, .tiff and .gif) the entire glass bottle gets some kind of tint to it, and blocks out part of the colors.

When I use the Metal Paint and add a label only the Metal Color shows in the bottle, the Base Color cannot be seen at all.
When I use regular Paint and add a label, the content becomes gray scaled.

Has anyone had the same problem? Can anyone help me? I would be overjoyed if I could only get a nudge in the right direction on this, because I am going absolutely crazy...




Couple of things to try...
Under your Project window. Go into settings, open the advanced triangle to get to the settings (if it's not open already). Try turning the ray bounces up. The default is 6, try switching it to 10 or 12 and see if that fixes it. You only want to go as high as you need to because it will slow your renders down.
Also, make sure "indirect Illumination" is checked on the same settings page too.


Forgot to mention...
If that looks good once you've made those changes, that only sets it for the render preview. You still have to go into "Render", then the "Quality" section and make sure the Ray Bounces are set to the same number there as well.


I had set the Ray Bounces up to 14 (my fiance's idea) because I was working with glass, so in the screenshots they're already up that high. I'll try the Indirect Lighting setting, and see if that does it... Thank you so much!


I tried the Indirect Lighting, it made it slightly better, but still not the way I wish.

I managed to accidentally make it right last night (the orange and purple), and rendered it fine, but when I opened the very same file that I had saved just after the correct render the next day, it was back to this crap. Could it be a bug in the new updates?

Chad Holton


Thanks! We have a new build available shortly that fixes this issue.