Typing in negative values does nothing

Started by mikalind, March 09, 2014, 10:13:31 PM

Previous topic - Next topic

0 Members and 1 Guest are viewing this topic.


Hahaha, yes i have.
And if i do the same thing as i said, with danish or US settings, it works just fine.

In fact, most of the instances in Keyshot where i affect settings with manually typing in negative values, this issue shows up.

And its a bit hard to get exact camera settings when i have to use the sliders.



Even if i cut&paste a negative value that worked when using the sliders, the camera does not react.


Morten Kristensen

Extremely weird indeed. Unfortunately, none of us here can reproduce it in any fashion.
I will create an issue in our bug tracker and then we'll follow up on it.

Hope you can manage.

Thanks and have a good day.


Hi again

I have installed Parallels Desktop and i run a demo version of Keyshot 4.3.18 there on windows 8.
No issue there.



I have the exact same problem - Keyshot 4 doesn't accept negative values from the keyboard. And just like mikalind I have a Swedish setup:

Mac OS X 10.9.2
Region: Sweden
Language: Sweden

Keyshot just seems to ignore typed negative values. I always been able to work around it by using the sliders and mouse positioning but now I've run into a wall with a camera movement.

It's troublesome that you don't seem to be able to reproduce this bug because it REALLY needs a fix! Please let me know if there is anything I can do to help.

Best regards ///Peter


Well, I found a quick workaround using the mouse scroll wheel. It's a bit iffy but seems to work in a pinch.

Position the cursor marker in the field (exactly!) and scroll up or down. This should change the number and you're able to reach negative values. However, if it's a big number you'll have to do A LOT of scrolling!  ;)